Read the docs
TI-2012-05269 Aliases CVE-2012-6551GHSA-34fp-xvxp-rg22

The default configuration of Apache ActiveMQ before 5.8.0 enables a sample web…

Priority LOW 33CWE-399Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Partial
Fix status
Partial Red Hat: 1 fixed, 1 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-399 and the CVSS impact.

Summary

The default configuration of Apache ActiveMQ before 5.8.0 enables a sample web application, which allows remote attackers to cause a denial of service (broker resource consumption) via HTTP requests.

Why it matters now

EPSS 0.07769 94th percentileScored 2026-11-07
Fix Partial org.apache.activemq:apache-activemq (Maven): 5.8.0org.apache.activemq:activemq-web-demo (Maven): 5.8.0Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.apache.activemq:apache-activemq (Maven)before 5.8.05.8.0Patch availableGHSA-34fp-xvxp-rg22
—org.apache.activemq:activemq-web-demo (Maven)before 5.8.05.8.0Patch availableGHSA-34fp-xvxp-rg22
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.apache.activemq:apache-activemq (Maven) Vendor— Affected before 5.8.0 Fixed in 5.8.0 Patch available GHSA-34fp-xvxp-rg22
  • org.apache.activemq:activemq-web-demo (Maven) Vendor— Affected before 5.8.0 Fixed in 5.8.0 Patch available GHSA-34fp-xvxp-rg22

CPE configurations NVD · 20

CPEVersionsRoleVendor
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*up to 5.7.0VulnerableApache
cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:*4.0VulnerableApache
cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:*4.0 m4VulnerableApache
cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:*4.0 rc2VulnerableApache
cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:*4.0.1VulnerableApache
cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:*4.0.2VulnerableApache
cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:*4.1.0VulnerableApache
cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:*4.1.1VulnerableApache
cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:*5.0.0VulnerableApache
cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:*5.1.0VulnerableApache
  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions up to 5.7.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:* Versions 4.0 m4 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:* Versions 4.0 rc2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Apache
Show 10 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:*5.2.0VulnerableApache
cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:*5.3.0VulnerableApache
cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:*5.3.1VulnerableApache
cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:*5.3.2VulnerableApache
cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:*5.4.0VulnerableApache
cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:*5.4.1VulnerableApache
cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:*5.4.2VulnerableApache
cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:*5.5.0VulnerableApache
cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:*5.5.1VulnerableApache
cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:*5.6.0VulnerableApache
  • cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* Versions 5.3.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* Versions 5.4.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* Versions 5.4.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* Versions 5.5.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* Versions 5.5.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* Versions 5.6.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-34fp-xvxp-rg22 org.apache.activemq:apache-activemq (Maven) Fixed in 5.8.0 Advisory →
  • Fix · GHSA-34fp-xvxp-rg22 org.apache.activemq:activemq-web-demo (Maven) Fixed in 5.8.0 Advisory →

Red Hat 1 advisory

  • RHSA-2013:1029 Released 2013-07-09 · Red Hat rating Important
    Fuse MQ Enterprise 7.1.0 update
    • Fuse MQ Enterprise 7.1.0

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat JBoss SOA Platform 4AffectedNo fix planned: Will not fix
Fuse MQ Enterprise 7.1.0Fixed RHSA-2013:1029
Not affected: 1 product
  • OpenShift Enterprise 1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-6551
  2. 2026-10-03 Alias added: GHSA-34fp-xvxp-rg22

References

  • TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
  • TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
  • TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
  • TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
  • TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
See all 74 →

Sources