Read the docs
TI-2012-05433 Aliases CVE-2012-10010GHSA-g973-76wm-xpmw

BestWebSoft Contact Form contact_form.php cntctfrm_settings_page cross-site request forgery

Priority LOW 38CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

A vulnerability was found in BestWebSoft Contact Form 3.21. It has been classified as problematic. This affects the function cntctfrm_settings_page of the file contact_form.php. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 3.22 is able to address this issue. The identifier of the patch is 8398d96ff0fe45ec9267d7259961c2ef89ed8005. It is recommended to upgrade the affected component. The identifier VDB-225321 was assigned to this vulnerability.

Why it matters now

EPSS 0.00361 30th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
BestWebSoftContact Form3.21—No fix listedCNA
  • Contact Form VendorBestWebSoft Affected 3.21 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:bestwebsoft:contact_form:3.21:*:*:*:*:wordpress:*:*3.21VulnerableBestWebSoft
  • cpe:2.3:a:bestwebsoft:contact_form:3.21:*:*:*:*:wordpress:*:* Versions 3.21 Vulnerable ·BestWebSoft

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-10010
  2. 2026-10-03 Alias added: GHSA-g973-76wm-xpmw

References

  • TI-2017-14121 BestWebSoft Contact Form Plugin Stored cross site scriting CVSS 3.1MEDIUM 5.4
  • TI-2017-13664 The contact-form-plugin plugin before 4.0.6 for WordPress has multiple XSS issues. CVSS 3.0MEDIUM 6.1
  • TI-2017-01471 Cross-site scripting in BestWebSoft Captcha CVSS 3.0MEDIUM 6.1
  • TI-2016-08907 The contact-form-plugin plugin before 4.0.2 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
  • TI-2015-07672 The contact-form-plugin plugin before 3.96 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
  • TI-2013-06133 The contact-form-plugin plugin before 3.3.5 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
See all 10 →

Sources