BestWebSoft Contact Form Plugin Stored cross site scriting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-80.
Summary
A vulnerability classified as problematic has been found in BestWebSoft Contact Form Plugin 4.0.0. This affects an unknown part. The manipulation leads to basic cross site scripting (Stored). It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.0.2 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BestWebSoft | Contact Form Plugin | 4.0.0 | — | No fix listed | CNA |
- Contact Form Plugin VendorBestWebSoft Affected 4.0.0 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bestwebsoft:contact_form:4.0.0:*:*:*:*:wordpress:*:* | 4.0.0 | Vulnerable | BestWebSoft |
- cpe:2.3:a:bestwebsoft:contact_form:4.0.0:*:*:*:*:wordpress:*:* Versions 4.0.0 Vulnerable ·BestWebSoft
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20055
- 2026-10-03 Alias added: GHSA-4g9g-f7m3-gwjm
References
More BestWebSoft Contact Form vulnerabilities
- TI-2012-05433 BestWebSoft Contact Form contact_form.php cntctfrm_settings_page cross-site request forgery CVSS 3.1HIGH 8.8
- TI-2017-13664 The contact-form-plugin plugin before 4.0.6 for WordPress has multiple XSS issues. CVSS 3.0MEDIUM 6.1
- TI-2017-01471 Cross-site scripting in BestWebSoft Captcha CVSS 3.0MEDIUM 6.1
- TI-2016-08907 The contact-form-plugin plugin before 4.0.2 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
- TI-2015-07672 The contact-form-plugin plugin before 3.96 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
- TI-2013-06133 The contact-form-plugin plugin before 3.3.5 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2017-20055 · CVE Program
- CVE-2017-20055 · NVD
- FIRST EPSS
- GHSA-4g9g-f7m3-gwjm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences