Front-end Editor < 2.3 - Arbitrary File Upload
Priority MEDIUM 55CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The Front End Editor plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation via the upload.php file in versions before 2.3. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.03847 90th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Front-end Editor (scribu): 2.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Front-end Editor (scribu) Fixed in 2.3
Timeline
- 2026-10-02 Threatist record created from CVE-2012-10019
- 2026-10-03 Alias added: GHSA-587g-h9jh-grjq
- 2026-10-20 EPSS moved to the 90th–95th percentile
References
Exploit 2
Advisory 2
Sources
- CVE-2012-10019 · CVE Program
- CVE-2012-10019 · NVD
- FIRST EPSS
- GHSA-587g-h9jh-grjq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences