FoxyPress <= 0.4.2.1 - Arbitrary File Upload
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The FoxyPress plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the uploadify.php file in versions up to, and including, 0.4.2.1. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WebMovementLLC | FoxyPress | before 0.4.2.2 | 0.4.2.2 | Patch available | CNA |
- FoxyPress VendorWebMovementLLC Affected before 0.4.2.2 Fixed in 0.4.2.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webmovementllc:foxypress:*:*:*:*:*:wordpress:*:* | up to 0.4.2.1 | Vulnerable | WebMovementLLC |
- cpe:2.3:a:webmovementllc:foxypress:*:*:*:*:*:wordpress:*:* Versions up to 0.4.2.1 Vulnerable ·WebMovementLLC
Remediation
- Fix · CNA FoxyPress (WebMovementLLC) Fixed in 0.4.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2012-10020
- 2026-10-03 Alias added: GHSA-jj57-5w64-pjmg
References
Exploit 3
Sources
- CVE-2012-10020 · CVE Program
- CVE-2012-10020 · NVD
- FIRST EPSS
- GHSA-jj57-5w64-pjmg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences