The nori gem 2.0.x before 2.0.2, 1.1.x before 1.1.4, and 1.0.x before 1.0.3 for Ruby does…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The nori gem 2.0.x before 2.0.2, 1.1.x before 1.1.4, and 1.0.x before 1.0.3 for Ruby does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | nori (RubyGems) | 2.0.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-4936-rj25-6wm6 |
| — | nori (RubyGems) | 1.1.0 to before 1.1.4 | 1.1.4 | Patch available | GHSA-4936-rj25-6wm6 |
| — | nori (RubyGems) | 1.0.0 to before 1.0.3 | 1.0.3 | Patch available | GHSA-4936-rj25-6wm6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- nori (RubyGems) Vendor— Affected 2.0.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-4936-rj25-6wm6
- nori (RubyGems) Vendor— Affected 1.1.0 to before 1.1.4 Fixed in 1.1.4 Patch available GHSA-4936-rj25-6wm6
- nori (RubyGems) Vendor— Affected 1.0.0 to before 1.0.3 Fixed in 1.0.3 Patch available GHSA-4936-rj25-6wm6
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nori_gem_project:nori_gem:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:1.1.3:*:*:*:*:*:*:* | 1.1.3 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Nori Gem Project |
| cpe:2.3:a:nori_gem_project:nori_gem:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | Nori Gem Project |
- cpe:2.3:a:nori_gem_project:nori_gem:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:1.1.3:*:*:*:*:*:*:* Versions 1.1.3 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Nori Gem Project
- cpe:2.3:a:nori_gem_project:nori_gem:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·Nori Gem Project
Remediation
- Fix · GHSA-4936-rj25-6wm6 nori (RubyGems) Fixed in 2.0.2 Advisory →
- Fix · GHSA-4936-rj25-6wm6 nori (RubyGems) Fixed in 1.1.4 Advisory →
- Fix · GHSA-4936-rj25-6wm6 nori (RubyGems) Fixed in 1.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-0285
- 2026-10-03 Alias added: GHSA-4936-rj25-6wm6
References
Advisory 2
Other 11
- [oss-security] 20130213 Some rubygems related CVEs
- https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately
- https://github.com/savonrb/nori/commit/2ca6f8603e406f884a8fcea6bc26f8f6bf168f40
- https://github.com/savonrb/nori/commit/4bcf59abdcec6bcd1153241b122eda61a494e4fb
- https://github.com/savonrb/nori/commit/818f5263b1d597b603d46cbe1702cd2717259e32
- https://github.com/savonrb/nori/commit/c3fdce7a2d2670b44f1cda35da0ae73cc1372084
- https://github.com/savonrb/nori/commit/c5e07f5c32e615f0a4a7ee2782d37f7a33261be4
- https://github.com/savonrb/nori/commit/d9b68667249b98776fb23ba9e9c548dc4b524709
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nori/CVE-2013-0285.yml
- https://github.com/savonrb/nori
- https://web.archive.org/web/20130203232028/https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately
Sources
- CVE-2013-0285 · CVE Program
- CVE-2013-0285 · NVD
- FIRST EPSS
- GHSA-4936-rj25-6wm6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences