Potential DoS through abuse of rate limit in libunity-webapps for Firefox
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-404.
Summary
The unity-firefox-extension package could be tricked into dropping a C callback which was still in use, which Firefox would then free, causing Firefox to crash. This could be achieved by adding an action to the launcher and updating it with new callbacks until the libunity-webapps rate limit was hit. Fixed in 3.0.0+14.04.20140416-0ubuntu1.14.04.1 of unity-firefox-extension and in all versions of libunity-webapps by shipping an empty unity-firefox-extension package, thus disabling the extension entirely and invalidating the attack against the libunity-webapps package.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | unity-firefox-extension | 3.0.0 to before 3.0.0+14.04.20140416-0ubuntu1.14.04.1 | 3.0.0+14.04.20140416-0ubuntu1.14.04.1 | Patch available | CNA |
| Canonical | libunity-webapps | 2.5.0 to before 2.5.0~+14.04.20140409-0ubuntu1 | 2.5.0~+14.04.20140409-0ubuntu1 | Patch available | CNA |
- unity-firefox-extension VendorCanonical Affected 3.0.0 to before 3.0.0+14.04.20140416-0ubuntu1.14.04.1 Fixed in 3.0.0+14.04.20140416-0ubuntu1.14.04.1 Patch available CNA
- libunity-webapps VendorCanonical Affected 2.5.0 to before 2.5.0~+14.04.20140409-0ubuntu1 Fixed in 2.5.0~+14.04.20140409-0ubuntu1 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:canonical:unity-firefox-extension:*:*:*:*:*:*:*:* | before 3.0.0\+14.04.20140416-0ubuntu1.14.04.1 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* | 15.04 | Vulnerable | Canonical |
- cpe:2.3:a:canonical:unity-firefox-extension:*:*:*:*:*:*:*:* Versions before 3.0.0\+14.04.20140416-0ubuntu1.14.04.1 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* Versions 15.04 Vulnerable ·Canonical
Remediation
- Fix · CNA unity-firefox-extension (Canonical) Fixed in 3.0.0+14.04.20140416-0ubuntu1.14.04.1
- Fix · CNA libunity-webapps (Canonical) Fixed in 2.5.0~+14.04.20140409-0ubuntu1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Canonical unity-firefox-extension — ubuntu.com/USN-2743-3
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2013-00916 Possible remote DOS in WebAppsPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2013-1055
- 2026-10-03 Alias added: GHSA-42p7-ggcc-r5fp
References
Exploit 1
Advisory 1
More Canonical Ubuntu Linux vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2013-1055 · CVE Program
- CVE-2013-1055 · NVD
- FIRST EPSS
- GHSA-42p7-ggcc-r5fp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences