Cross-site scripting (XSS) vulnerability in the Portfolio publisher servlet in the demo…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Portfolio publisher servlet in the demo web application in Apache ActiveMQ before 5.9.0 allows remote attackers to inject arbitrary web script or HTML via the refresh parameter to demo/portfolioPublish, a different vulnerability than CVE-2012-6092.
Why it matters now
EPSS 0.06791 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.apache.activemq:activemq-core (Maven): 5.9.0Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.activemq:activemq-core (Maven) | before 5.9.0 | 5.9.0 | Patch available | GHSA-c9gx-27hq-wcvj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.activemq:activemq-core (Maven) Vendor— Affected before 5.9.0 Fixed in 5.9.0 Patch available GHSA-c9gx-27hq-wcvj
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* | up to 5.8.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* | 5.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* | 5.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* | 5.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* | 5.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* | 5.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* | 5.3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* | 5.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* | 5.4.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* | 5.4.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions up to 5.8.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* Versions 5.3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* Versions 5.4.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* Versions 5.4.2 Vulnerable ·Apache
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* | 5.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* | 5.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* | 5.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.7.0:*:*:*:*:*:*:* | 5.7.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* Versions 5.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* Versions 5.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* Versions 5.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.7.0:*:*:*:*:*:*:* Versions 5.7.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-c9gx-27hq-wcvj org.apache.activemq:activemq-core (Maven) Fixed in 5.9.0 Advisory →
Red Hat 1 advisory
- RHSA-2013:1029 Released 2013-07-09 · Red Hat rating ImportantFuse MQ Enterprise 7.1.0 update
- Fuse MQ Enterprise 7.1.0
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Fuse MQ Enterprise 7.1.0 | Fixed | RHSA-2013:1029 |
Not affected: 1 product
- OpenShift Enterprise 1
Timeline
- 2026-10-02 Threatist record created from CVE-2013-1880
- 2026-10-03 Alias added: GHSA-c9gx-27hq-wcvj
References
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2013-1880 · CVE Program
- CVE-2013-1880 · NVD
- FIRST EPSS
- GHSA-c9gx-27hq-wcvj · GitHub Advisory Database · CC BY 4.0
- CVE-2013-1880 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences