Cross-site scripting (XSS) vulnerability in Jenkins before 1.514, LTS before 1.509.1, and…
Priority LOW 15CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Jenkins before 1.514, LTS before 1.509.1, and Enterprise 1.466.x before 1.466.14.1 and 1.480.x before 1.480.4.1 allows remote authenticated users with write permission to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.01912 79th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 1.509.1, 1.514
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.509.1 | 1.509.1 | Patch available | GHSA-826f-32qm-vm3j |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.513 to before 1.514 | 1.514 | Patch available | GHSA-826f-32qm-vm3j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.509.1 Fixed in 1.509.1 Patch available GHSA-826f-32qm-vm3j
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.513 to before 1.514 Fixed in 1.514 Patch available GHSA-826f-32qm-vm3j
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* | before 1.509.1 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* | before 1.514 | Vulnerable | Jenkins |
| cpe:2.3:a:cloudbees:jenkins:*:*:*:*:enterprise:*:*:* | 1.466 to before 1.466.14.1; 1.480 to before 1.480.4.1 | Vulnerable | CloudBees |
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 1.509.1 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions before 1.514 Vulnerable ·Jenkins
- cpe:2.3:a:cloudbees:jenkins:*:*:*:*:enterprise:*:*:* Versions 1.466 to before 1.466.14.1; 1.480 to before 1.480.4.1 Vulnerable ·CloudBees
Remediation
- Fix · GHSA-826f-32qm-vm3j org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.509.1 Advisory →
- Fix · GHSA-826f-32qm-vm3j org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.514 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| RHOSE Client 1.2 | Fixed | — |
| RHOSE Infrastructure 1.2 | Fixed | — |
| Red Hat OpenShift Enterprise Node | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-2033
- 2026-10-03 Alias added: GHSA-826f-32qm-vm3j
References
Advisory 2
Sources
- CVE-2013-2033 · CVE Program
- CVE-2013-2033 · NVD
- FIRST EPSS
- GHSA-826f-32qm-vm3j · GitHub Advisory Database · CC BY 4.0
- CVE-2013-2033 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences