Multiple cross-site request forgery (CSRF) vulnerabilities in Jenkins before 1.514, LTS…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-352.
Summary
Multiple cross-site request forgery (CSRF) vulnerabilities in Jenkins before 1.514, LTS before 1.509.1, and Enterprise 1.466.x before 1.466.14.1 and 1.480.x before 1.480.4.1 allow remote attackers to hijack the authentication of administrators for requests that (1) execute arbitrary code or (2) initiate deployment of binaries to a Maven repository via unspecified vectors.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.509.1 | 1.509.1 | Patch available | GHSA-fg4r-f9j2-36mw |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.513 to before 1.514 | 1.514 | Patch available | GHSA-fg4r-f9j2-36mw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.509.1 Fixed in 1.509.1 Patch available GHSA-fg4r-f9j2-36mw
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.513 to before 1.514 Fixed in 1.514 Patch available GHSA-fg4r-f9j2-36mw
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudbees:jenkins:*:*:*:*:*:*:*:* | up to 1.513 | Vulnerable | CloudBees |
| cpe:2.3:a:cloudbees:jenkins:1.466:*:*:*:enterprise:*:*:* | 1.466 | Vulnerable | CloudBees |
| cpe:2.3:a:cloudbees:jenkins:1.480:*:*:*:enterprise:*:*:* | 1.480 | Vulnerable | CloudBees |
| cpe:2.3:a:cloudbees:jenkins:1.509:*:*:*:lts:*:*:* | 1.509 | Vulnerable | CloudBees |
- cpe:2.3:a:cloudbees:jenkins:*:*:*:*:*:*:*:* Versions up to 1.513 Vulnerable ·CloudBees
- cpe:2.3:a:cloudbees:jenkins:1.466:*:*:*:enterprise:*:*:* Versions 1.466 Vulnerable ·CloudBees
- cpe:2.3:a:cloudbees:jenkins:1.480:*:*:*:enterprise:*:*:* Versions 1.480 Vulnerable ·CloudBees
- cpe:2.3:a:cloudbees:jenkins:1.509:*:*:*:lts:*:*:* Versions 1.509 Vulnerable ·CloudBees
Remediation
- Fix · GHSA-fg4r-f9j2-36mw org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.509.1 Advisory →
- Fix · GHSA-fg4r-f9j2-36mw org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.514 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| RHOSE Client 1.2 | Fixed | — |
| RHOSE Infrastructure 1.2 | Fixed | — |
| Red Hat OpenShift Enterprise Node | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-2034
- 2026-10-03 Alias added: GHSA-fg4r-f9j2-36mw
References
Advisory 2
Other 7
- 92981
- https://access.redhat.com/errata/RHEA-2013:1032
- https://access.redhat.com/security/cve/CVE-2013-2034
- https://bugzilla.redhat.com/show_bug.cgi?id=958958
- https://issues.jenkins-ci.org/browse/SECURITY-63
- https://issues.jenkins-ci.org/browse/SECURITY-69
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2013-05-02
More CloudBees Jenkins vulnerabilities
- TI-2012-00722 Uncontrolled resource consumption in Jenkins CVSS 3.1HIGH 7.5
- TI-2012-05037 Open redirect vulnerability in Jenkins before 1.491, Jenkins LTS before 1.480.1, and… CVSS 2.0MEDIUM 5.8
- TI-2012-05036 CRLF injection vulnerability in Jenkins before 1.491, Jenkins LTS before 1.480.1, and… CVSS 2.0MEDIUM 4.3
- TI-2012-00312 Cross-site scripting (XSS) vulnerability in Jenkins before 1.454, Jenkins LTS before… CVSS 2.0MEDIUM 4.3
- TI-2012-00311 Cross-site scripting (XSS) vulnerability in Jenkins before 1.454, Jenkins LTS before… CVSS 2.0MEDIUM 4.3
- TI-2012-05038 Cross-site scripting (XSS) vulnerability in Jenkins before 1.491, Jenkins LTS before… CVSS 2.0LOW 3.5
Sources
- CVE-2013-2034 · CVE Program
- CVE-2013-2034 · NVD
- FIRST EPSS
- GHSA-fg4r-f9j2-36mw · GitHub Advisory Database · CC BY 4.0
- CVE-2013-2034 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences