Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code…
Priority HIGH 74CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Apache Struts 2 before 2.3.14.2 allows remote attackers to execute arbitrary OGNL code via a crafted request that is not properly handled when using the includeParams attribute in the (1) URL or (2) A tag. NOTE: this issue is due to an incomplete fix for CVE-2013-1966.
Why it matters now
EPSS 0.74636 99th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.14.2org.apache.struts.xwork:xwork-core (Maven): 2.3.14.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.0 to before 2.3.14.2 | 2.3.14.2 | Patch available | GHSA-7ghm-rpc7-p7g5 |
| — | org.apache.struts.xwork:xwork-core (Maven) | 2.0.0 to before 2.3.14.2 | 2.3.14.2 | Patch available | GHSA-7ghm-rpc7-p7g5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 to before 2.3.14.2 Fixed in 2.3.14.2 Patch available GHSA-7ghm-rpc7-p7g5
- org.apache.struts.xwork:xwork-core (Maven) Vendor— Affected 2.0.0 to before 2.3.14.2 Fixed in 2.3.14.2 Patch available GHSA-7ghm-rpc7-p7g5
Remediation
- Fix · GHSA-7ghm-rpc7-p7g5 org.apache.struts:struts2-core (Maven) Fixed in 2.3.14.2 Advisory →
- Fix · GHSA-7ghm-rpc7-p7g5 org.apache.struts.xwork:xwork-core (Maven) Fixed in 2.3.14.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 5
Timeline
- 2026-10-02 Threatist record created from CVE-2013-2115
- 2026-10-03 Alias added: GHSA-7ghm-rpc7-p7g5
References
Advisory 3
Other 9
- https://bugzilla.redhat.com/show_bug.cgi?id=967656
- https://github.com/apache/struts/commit/d7804297e319c7a12245e1b536e565fcea6d650
- https://github.com/apache/struts/commit/d934c6e7430b7b98e43a0a085a2304bd31a75c3d
- https://github.com/apache/struts/commit/ea96d18d0f75c390d2595648efa3563785c272c6
- https://github.com/apache/struts/commit/fed4f8e8a4ec69b5e7612b92d8ce3e476680474
- https://cwiki.apache.org/confluence/display/WW/S2-013
- https://github.com/apache/struts
- https://issues.apache.org/jira/browse/WW-4063
- https://web.archive.org/web/20140212000331/http://www.securityfocus.com/bid/60167
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2013-2115 · CVE Program
- CVE-2013-2115 · NVD
- FIRST EPSS
- GHSA-7ghm-rpc7-p7g5 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-2115 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences