The web console in Apache ActiveMQ before 5.8.0 does not require authentication, which…
Priority LOW 38CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · None · Partial
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.
Summary
The web console in Apache ActiveMQ before 5.8.0 does not require authentication, which allows remote attackers to obtain sensitive information or cause a denial of service via HTTP requests.
Why it matters now
EPSS 0.06311 93rd percentileScored 2026-11-07
Fix Partial org.apache.activemq:activemq-client (Maven): 5.8.0Red Hat: 2 advisoriesRed Hat: 2 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.activemq:activemq-client (Maven) | before 5.8.0 | 5.8.0 | Patch available | GHSA-p358-58jj-hp65 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.activemq:activemq-client (Maven) Vendor— Affected before 5.8.0 Fixed in 5.8.0 Patch available GHSA-p358-58jj-hp65
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* | up to 5.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:* | 4.0 m4 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:* | 4.0 rc2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* | 5.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* | 5.1.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions up to 5.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:* Versions 4.0 m4 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:* Versions 4.0 rc2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Apache
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* | 5.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* | 5.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* | 5.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* | 5.3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* | 5.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* | 5.4.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* | 5.4.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* | 5.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* | 5.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* | 5.6.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* Versions 5.3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* Versions 5.4.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* Versions 5.4.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* Versions 5.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* Versions 5.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* Versions 5.6.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-p358-58jj-hp65 org.apache.activemq:activemq-client (Maven) Fixed in 5.8.0 Advisory →
Red Hat 2 advisories
- RHSA-2013:1221 Released 2013-09-09 · Red Hat rating ImportantFuse Message Broker 5.5.1 security update
- Fuse Message Broker 5.5.1
- RHSA-2013:1029 Released 2013-07-09 · Red Hat rating ImportantFuse MQ Enterprise 7.1.0 update
- Fuse MQ Enterprise 7.1.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix yet |
| Red Hat JBoss SOA Platform 4 | Affected | No fix planned: Will not fix |
| Fuse MQ Enterprise 7.1.0 | Fixed | RHSA-2013:1029 |
| Fuse Message Broker 5.5.1 | Fixed | RHSA-2013:1221 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-3060
- 2026-10-03 Alias added: GHSA-p358-58jj-hp65
References
Other 9
- [dev] 20121022 [DISCUSS] - ActiveMQ out of the box - Should not include the demos
- https://fisheye6.atlassian.com/changelog/activemq?cs=1404998
- http://activemq.apache.org/activemq-580-release.html
- https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12323282
- https://issues.apache.org/jira/browse/AMQ-4124
- https://github.com/apache/activemq/commit/22bc55b9487df98a3c3cb04f99f4618fcba364fe
- https://github.com/apache/activemq/commit/437ea2f6e58d18837ae0e68dcd2fdadc1fff3723
- https://github.com/apache/activemq/commit/ced33d2551a040813cb40bd6d36fdd322034fa73
- https://github.com/apache/activemq
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2013-3060 · CVE Program
- CVE-2013-3060 · NVD
- FIRST EPSS
- GHSA-p358-58jj-hp65 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-3060 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences