Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute…
Priority LOW 34CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename of an email attachment.
Why it matters now
EPSS 0.02138 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed sup (RubyGems): 0.13.2.1, 0.14.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | sup (RubyGems) | before 0.13.2.1 | 0.13.2.1 | Patch available | GHSA-5f2p-6vjv-2q2m |
| — | sup (RubyGems) | 0.14.0 to before 0.14.1.1 | 0.14.1.1 | Patch available | GHSA-5f2p-6vjv-2q2m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- sup (RubyGems) Vendor— Affected before 0.13.2.1 Fixed in 0.13.2.1 Patch available GHSA-5f2p-6vjv-2q2m
- sup (RubyGems) Vendor— Affected 0.14.0 to before 0.14.1.1 Fixed in 0.14.1.1 Patch available GHSA-5f2p-6vjv-2q2m
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:supmua:sup:*:*:*:*:*:*:*:* | up to 0.13.2 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.13.0:*:*:*:*:*:*:* | 0.13.0 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.13.1:*:*:*:*:*:*:* | 0.13.1 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.14.0:*:*:*:*:*:*:* | 0.14.0 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.14.1:*:*:*:*:*:*:* | 0.14.1 | Vulnerable | Supmua |
- cpe:2.3:a:supmua:sup:*:*:*:*:*:*:*:* Versions up to 0.13.2 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.13.0:*:*:*:*:*:*:* Versions 0.13.0 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.13.1:*:*:*:*:*:*:* Versions 0.13.1 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.14.0:*:*:*:*:*:*:* Versions 0.14.0 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.14.1:*:*:*:*:*:*:* Versions 0.14.1 Vulnerable ·Supmua
Remediation
- Fix · GHSA-5f2p-6vjv-2q2m sup (RubyGems) Fixed in 0.13.2.1 Advisory →
- Fix · GHSA-5f2p-6vjv-2q2m sup (RubyGems) Fixed in 0.14.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4478
- 2026-10-03 Alias added: GHSA-5f2p-6vjv-2q2m
References
Other 8
- [sup-talk] 20130818 Fwd: Security issue with suggested configuration of sup
- [sup-talk] 20131029 Security advisory, releases 0.13.2.1 and 0.14.1.1
- [oss-security] 20131029 Re: CVE Request: sup MUA Command Injection
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sup/CVE-2013-4478.yml
- https://github.com/sup-heliotrope/sup
- https://web.archive.org/web/20140524005344/http://rubyforge.org/pipermail/sup-talk/2013-October/004996.html
- https://web.archive.org/web/20140524012714/http://rubyforge.org/pipermail/sup-talk/2013-August/004993.html
- http://www.phenoelit.org/stuff/whatsup.txt
More Supmua Sup vulnerabilities
- TI-2013-03928 lib/sup/message_chunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2013-4478 · CVE Program
- CVE-2013-4478 · NVD
- FIRST EPSS
- GHSA-5f2p-6vjv-2q2m · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4478 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences