lib/sup/message_chunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote…
Priority LOW 36CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
lib/sup/message_chunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the content_type of an email attachment.
Why it matters now
EPSS 0.03239 88th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed sup (RubyGems): 0.13.2.1, 0.14.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | sup (RubyGems) | before 0.13.2.1 | 0.13.2.1 | Patch available | GHSA-hh2x-7mf9-78fr |
| — | sup (RubyGems) | 0.14.0 to before 0.14.1.1 | 0.14.1.1 | Patch available | GHSA-hh2x-7mf9-78fr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- sup (RubyGems) Vendor— Affected before 0.13.2.1 Fixed in 0.13.2.1 Patch available GHSA-hh2x-7mf9-78fr
- sup (RubyGems) Vendor— Affected 0.14.0 to before 0.14.1.1 Fixed in 0.14.1.1 Patch available GHSA-hh2x-7mf9-78fr
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:supmua:sup:*:*:*:*:*:*:*:* | up to 0.13.2 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.13.0:*:*:*:*:*:*:* | 0.13.0 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.13.1:*:*:*:*:*:*:* | 0.13.1 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.14.0:*:*:*:*:*:*:* | 0.14.0 | Vulnerable | Supmua |
| cpe:2.3:a:supmua:sup:0.14.1:*:*:*:*:*:*:* | 0.14.1 | Vulnerable | Supmua |
- cpe:2.3:a:supmua:sup:*:*:*:*:*:*:*:* Versions up to 0.13.2 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.13.0:*:*:*:*:*:*:* Versions 0.13.0 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.13.1:*:*:*:*:*:*:* Versions 0.13.1 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.14.0:*:*:*:*:*:*:* Versions 0.14.0 Vulnerable ·Supmua
- cpe:2.3:a:supmua:sup:0.14.1:*:*:*:*:*:*:* Versions 0.14.1 Vulnerable ·Supmua
Remediation
- Fix · GHSA-hh2x-7mf9-78fr sup (RubyGems) Fixed in 0.13.2.1 Advisory →
- Fix · GHSA-hh2x-7mf9-78fr sup (RubyGems) Fixed in 0.14.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4479
- 2026-10-03 Alias added: GHSA-hh2x-7mf9-78fr
References
Other 7
- 20131029 Advisory: sup MUA Command Injection
- [sup-talk] 20131029 Security advisory, releases 0.13.2.1 and 0.14.1.1
- [oss-security] 20131029 Re: CVE Request: sup MUA Command Injection
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sup/CVE-2013-4479.yml
- https://github.com/sup-heliotrope/sup
- https://web.archive.org/web/20140524005344/http://rubyforge.org/pipermail/sup-talk/2013-October/004996.html
- http://www.phenoelit.org/stuff/whatsup.txt
More Supmua Sup vulnerabilities
- TI-2013-03927 Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2013-4479 · CVE Program
- CVE-2013-4479 · NVD
- FIRST EPSS
- GHSA-hh2x-7mf9-78fr · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4479 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences