The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote…
Priority LOW 31CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.
Why it matters now
EPSS 0.01015 63rd percentileScored 2026-11-07
Fix Fixed civicrm/civicrm-core (Packagist): 4.2.9, 4.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | civicrm/civicrm-core (Packagist) | 4.2.0 to before 4.2.9 | 4.2.9 | Patch available | GHSA-4465-r2hg-v4rj |
| — | civicrm/civicrm-core (Packagist) | 4.3.0 to before 4.3.3 | 4.3.3 | Patch available | GHSA-4465-r2hg-v4rj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- civicrm/civicrm-core (Packagist) Vendor— Affected 4.2.0 to before 4.2.9 Fixed in 4.2.9 Patch available GHSA-4465-r2hg-v4rj
- civicrm/civicrm-core (Packagist) Vendor— Affected 4.3.0 to before 4.3.3 Fixed in 4.3.3 Patch available GHSA-4465-r2hg-v4rj
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:civicrm:civicrm:4.2.0:*:*:*:*:*:*:* | 4.2.0 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.1:*:*:*:*:*:*:* | 4.2.1 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.2:*:*:*:*:*:*:* | 4.2.2 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.4:*:*:*:*:*:*:* | 4.2.4 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.5:*:*:*:*:*:*:* | 4.2.5 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.6:*:*:*:*:*:*:* | 4.2.6 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.7:*:*:*:*:*:*:* | 4.2.7 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.8:*:*:*:*:*:*:* | 4.2.8 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.2.9:*:*:*:*:*:*:* | 4.2.9 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:4.3.0:*:*:*:*:*:*:* | 4.3.0 | Vulnerable | CiviCRM |
- cpe:2.3:a:civicrm:civicrm:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.1:*:*:*:*:*:*:* Versions 4.2.1 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.2:*:*:*:*:*:*:* Versions 4.2.2 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.4:*:*:*:*:*:*:* Versions 4.2.4 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.5:*:*:*:*:*:*:* Versions 4.2.5 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.6:*:*:*:*:*:*:* Versions 4.2.6 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.7:*:*:*:*:*:*:* Versions 4.2.7 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.8:*:*:*:*:*:*:* Versions 4.2.8 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.2.9:*:*:*:*:*:*:* Versions 4.2.9 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:4.3.0:*:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·CiviCRM
Remediation
- Fix · GHSA-4465-r2hg-v4rj civicrm/civicrm-core (Packagist) Fixed in 4.2.9 Advisory →
- Fix · GHSA-4465-r2hg-v4rj civicrm/civicrm-core (Packagist) Fixed in 4.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4662
- 2026-10-03 Alias added: GHSA-4465-r2hg-v4rj
References
More Civicrm vulnerabilities
- TI-2025-40285 A Stored Cross Site Scripting vulnerability exists in CiviCRM before v6.7 in the… CVSS 3.1MEDIUM 6.1
- TI-2023-10751 Stored Cross Site Scripting (XSS) vulnerability in the add contact function CiviCRM… CVSS 3.1MEDIUM 5.4
- TI-2018-16163 PEAR HTML_QuickForm version 3.2.14 contains an eval injection (CWE-95) vulnerability in… CVSS 3.0CRITICAL 9.8
- TI-2020-18643 In CiviCRM before 5.21.3 and 5.22.x through 5.24.x before 5.24.3, users may be able to… CVSS 3.1HIGH 8.8
- TI-2013-05077 Multiple SQL injection vulnerabilities in CRM/Core/Page/AJAX/Location.php in CiviCRM… CVSS 2.0HIGH 7.5
- TI-2013-01438 Cross-site scripting (XSS) vulnerability in open-flash-chart.swf in Open Flash Chart (aka… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2013-4662 · CVE Program
- CVE-2013-4662 · NVD
- FIRST EPSS
- GHSA-4465-r2hg-v4rj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences