The DocumentAnalysisRequestHandler in Apache Solr before 4.3.1 does not properly use the…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
The DocumentAnalysisRequestHandler in Apache Solr before 4.3.1 does not properly use the EmptyEntityResolver, which allows remote attackers to have an unspecified impact via XML data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-6407.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.solr:solr-core (Maven) | before 4.3.1 | 4.3.1 | Patch available | GHSA-45w3-2hvv-pfxq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.solr:solr-core (Maven) Vendor— Affected before 4.3.1 Fixed in 4.3.1 Patch available GHSA-45w3-2hvv-pfxq
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:solr:*:*:*:*:*:*:*:* | up to 4.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:3.6.0:*:*:*:*:*:*:* | 3.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:3.6.1:*:*:*:*:*:*:* | 3.6.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:3.6.2:*:*:*:*:*:*:* | 3.6.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.0.0:alpha:*:*:*:*:*:* | 4.0.0 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.0.0:beta:*:*:*:*:*:* | 4.0.0 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.2.0:*:*:*:*:*:*:* | 4.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.2.1:*:*:*:*:*:*:* | 4.2.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:solr:*:*:*:*:*:*:*:* Versions up to 4.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:3.6.0:*:*:*:*:*:*:* Versions 3.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:3.6.1:*:*:*:*:*:*:* Versions 3.6.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:3.6.2:*:*:*:*:*:*:* Versions 3.6.2 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.0.0:alpha:*:*:*:*:*:* Versions 4.0.0 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.0.0:beta:*:*:*:*:*:* Versions 4.0.0 beta Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.2.1:*:*:*:*:*:*:* Versions 4.2.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-45w3-2hvv-pfxq org.apache.solr:solr-core (Maven) Fixed in 4.3.1 Advisory →
Red Hat 2 advisories
- RHSA-2014:0029 Released 2014-01-15 · Red Hat rating ImportantRed Hat JBoss Data Grid 6.2.0 update
- Red Hat JBoss Data Grid 6.2
- RHSA-2013:1844 Released 2013-12-16 · Red Hat rating ImportantRed Hat JBoss Web Framework Kit 2.4.0 update
- Red Hat JBoss Web Framework Kit 2.4
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Data Grid 6.2 | Fixed | RHSA-2014:0029 |
| Red Hat JBoss Web Framework Kit 2.4 | Fixed | RHSA-2013:1844 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-6408
- 2026-10-03 Alias added: GHSA-45w3-2hvv-pfxq
References
More Apache Solr vulnerabilities
- TI-2024-30303 Apache Solr: Authentication bypass possible using a fake URL Path ending CVSS 3.1CRITICAL 9.8
- TI-2019-13101 Injection in Apache Solr KEVCVSS 3.1HIGH 7.5
- TI-2019-00170 Code injection in Apache Solr KEVCVSS 3.1HIGH 7.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2021-09240 SSRF vulnerability with the Replication handler CVSS 3.1CRITICAL 9.8
- TI-2017-09354 XML external entity injection in Apache Solr before 7.1 with Apache Lucene before 7.1 CVSS 3.1CRITICAL 9.8
Sources
- CVE-2013-6408 · CVE Program
- CVE-2013-6408 · NVD
- FIRST EPSS
- GHSA-45w3-2hvv-pfxq · GitHub Advisory Database · CC BY 4.0
- CVE-2013-6408 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences