ParametersInterceptor in Apache Struts before 2.3.20 does not properly restrict access to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264.
Summary
ParametersInterceptor in Apache Struts before 2.3.20 does not properly restrict access to the getClass method, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via a crafted request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0094.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | before 2.3.20 | 2.3.20 | Patch available | GHSA-prjv-jj26-wf8h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected before 2.3.20 Fixed in 2.3.20 Patch available GHSA-prjv-jj26-wf8h
Remediation
- Fix · GHSA-prjv-jj26-wf8h org.apache.struts:struts2-core (Maven) Fixed in 2.3.20 Advisory →
Red Hat 1 advisory
- RHSA-2019:0910 Released 2019-04-30 · Red Hat rating ImportantRed Hat Fuse 7.3 security update
- Red Hat Fuse 7.3
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7.3 | Fixed | RHSA-2019:0910 |
Not affected: 4 products
- Red Hat Enterprise Linux 5
- Red Hat Fuse 7
- Red Hat JBoss Fuse 6
- Red Hat JBoss Operations Network 3
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0112
- 2026-10-03 Alias added: GHSA-prjv-jj26-wf8h
References
Advisory 8
- http://packetstormsecurity.com/files/127215/VMware-Security-Advisory-2014-0007.html
- http://www.vmware.com/security/advisories/VMSA-2014-0007.html
- http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html
- JVN#19294237
- JVNDB-2014-000045
- http://www-01.ibm.com/support/docview.wss?uid=swg21676706
- RHSA-2019:0910
- https://nvd.nist.gov/vuln/detail/CVE-2014-0112
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2014-0112 · CVE Program
- CVE-2014-0112 · NVD
- FIRST EPSS
- GHSA-prjv-jj26-wf8h · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0112 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences