Cross-site scripting (XSS) vulnerability in view.cgi in Webmin before 1.680 allows remote…
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in view.cgi in Webmin before 1.680 allows remote attackers to inject arbitrary web script or HTML via the search parameter.
Why it matters now
EPSS 0.01574 75th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webmin:webmin:*:*:*:*:*:*:*:* | up to 1.670 | Vulnerable | Webmin |
| cpe:2.3:a:webmin:webmin:1.600:*:*:*:*:*:*:* | 1.600 | Vulnerable | Webmin |
| cpe:2.3:a:webmin:webmin:1.610:*:*:*:*:*:*:* | 1.610 | Vulnerable | Webmin |
| cpe:2.3:a:webmin:webmin:1.620:*:*:*:*:*:*:* | 1.620 | Vulnerable | Webmin |
| cpe:2.3:a:webmin:webmin:1.630:*:*:*:*:*:*:* | 1.630 | Vulnerable | Webmin |
| cpe:2.3:a:webmin:webmin:1.640:*:*:*:*:*:*:* | 1.640 | Vulnerable | Webmin |
| cpe:2.3:a:webmin:webmin:1.650:*:*:*:*:*:*:* | 1.650 | Vulnerable | Webmin |
| cpe:2.3:a:webmin:webmin:1.660:*:*:*:*:*:*:* | 1.660 | Vulnerable | Webmin |
- cpe:2.3:a:webmin:webmin:*:*:*:*:*:*:*:* Versions up to 1.670 Vulnerable ·Webmin
- cpe:2.3:a:webmin:webmin:1.600:*:*:*:*:*:*:* Versions 1.600 Vulnerable ·Webmin
- cpe:2.3:a:webmin:webmin:1.610:*:*:*:*:*:*:* Versions 1.610 Vulnerable ·Webmin
- cpe:2.3:a:webmin:webmin:1.620:*:*:*:*:*:*:* Versions 1.620 Vulnerable ·Webmin
- cpe:2.3:a:webmin:webmin:1.630:*:*:*:*:*:*:* Versions 1.630 Vulnerable ·Webmin
- cpe:2.3:a:webmin:webmin:1.640:*:*:*:*:*:*:* Versions 1.640 Vulnerable ·Webmin
- cpe:2.3:a:webmin:webmin:1.650:*:*:*:*:*:*:* Versions 1.650 Vulnerable ·Webmin
- cpe:2.3:a:webmin:webmin:1.660:*:*:*:*:*:*:* Versions 1.660 Vulnerable ·Webmin
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0339
- 2026-10-03 Alias added: GHSA-pgqx-h99c-xmqg
References
More Webmin vulnerabilities
- TI-2019-11278 An issue was discovered in Webmin <=1.920. KEVCVSS 3.1CRITICAL 9.8
- TI-2022-16770 software/apt-lib.pl in Webmin before 1.997 lacks HTML escaping for a UI command. CVSS 3.1CRITICAL 9.8
- TI-2022-00731 Improper Access Control to Remote Code Execution in webmin/webmin CVSS 3.1HIGH 8.8
- TI-2019-09619 In Webmin through 1.910, any user authorized to the "Package Updates" module can execute… CVSS 3.0HIGH 8.8
- TI-2021-11777 Webmin 1.973 is affected by reflected Cross Site Scripting (XSS) to achieve Remote… CVSS 3.1CRITICAL 9.6
- TI-2024-11888 OS command injection in Webmin CVSS 3.1HIGH 8.8
Sources
- CVE-2014-0339 · CVE Program
- CVE-2014-0339 · NVD
- FIRST EPSS
- GHSA-pgqx-h99c-xmqg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences