The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "\" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | python-gnupg (PyPI) | 0.3.5 to before 0.3.6 | 0.3.6 | Patch available | GHSA-2jc8-4r6g-282j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- python-gnupg (PyPI) Vendor— Affected 0.3.5 to before 0.3.6 Fixed in 0.3.6 Patch available GHSA-2jc8-4r6g-282j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python-gnupg_project:python-gnupg:*:*:*:*:*:*:*:* | up to 0.3.5 | Vulnerable | Python-gnupg Project |
- cpe:2.3:a:python-gnupg_project:python-gnupg:*:*:*:*:*:*:*:* Versions up to 0.3.5 Vulnerable ·Python-gnupg Project
Remediation
- Fix · GHSA-2jc8-4r6g-282j python-gnupg (PyPI) Fixed in 0.3.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-1928
- 2026-10-03 Alias added: GHSA-2jc8-4r6g-282j
References
Exploit 3
Advisory 3
More Python-gnupg Project Python-gnupg vulnerabilities
- TI-2014-01502 The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which… CVSS 2.0HIGH 7.5
- TI-2014-01504 python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified… CVSS 2.0MEDIUM 4.4
Sources
- CVE-2014-1928 · CVE Program
- CVE-2014-1928 · NVD
- FIRST EPSS
- GHSA-2jc8-4r6g-282j · GitHub Advisory Database · CC BY 4.0
- CVE-2014-1928 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences