python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified…
Priority LOW 21CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
Why it matters now
EPSS 0.00386 32nd percentileScored 2026-11-07
Fix Fixed python-gnupg (PyPI): 0.3.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | python-gnupg (PyPI) | 0.3.5 to before 0.3.7 | 0.3.7 | Patch available | GHSA-vcr5-xr9h-mvc5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- python-gnupg (PyPI) Vendor— Affected 0.3.5 to before 0.3.7 Fixed in 0.3.7 Patch available GHSA-vcr5-xr9h-mvc5
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python-gnupg_project:python-gnupg:0.3.5:*:*:*:*:*:*:* | 0.3.5 | Vulnerable | Python-gnupg Project |
| cpe:2.3:a:python-gnupg_project:python-gnupg:0.3.6:*:*:*:*:*:*:* | 0.3.6 | Vulnerable | Python-gnupg Project |
- cpe:2.3:a:python-gnupg_project:python-gnupg:0.3.5:*:*:*:*:*:*:* Versions 0.3.5 Vulnerable ·Python-gnupg Project
- cpe:2.3:a:python-gnupg_project:python-gnupg:0.3.6:*:*:*:*:*:*:* Versions 0.3.6 Vulnerable ·Python-gnupg Project
Remediation
- Fix · GHSA-vcr5-xr9h-mvc5 python-gnupg (PyPI) Fixed in 0.3.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-1929
- 2026-10-03 Alias added: GHSA-vcr5-xr9h-mvc5
References
Advisory 3
Other 9
- [oss-security] 20140204 Re: CVE request: python-gnupg before 0.3.5 shell injection
- [oss-security] 20140212 Re: CVE request: python-gnupg before 0.3.5 shell injection
- https://alioth-lists.debian.net/pipermail/debian-security-tracker-commits/2014-June/028512.html
- https://code.google.com/archive/p/python-gnupg/issues/98
- https://github.com/pypa/advisory-database/tree/main/vulns/python-gnupg/PYSEC-2014-92.yaml
- https://github.com/vsajip/python-gnupg
- https://web.archive.org/web/20200228170437/http://www.securityfocus.com/bid/65539
- https://www.openwall.com/lists/oss-security/2014/02/04/3
- https://www.openwall.com/lists/oss-security/2014/02/04/4
More Python-gnupg Project Python-gnupg vulnerabilities
- TI-2014-01502 The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which… CVSS 2.0HIGH 7.5
- TI-2014-01503 The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which… CVSS 2.0MEDIUM 4.6
Sources
- CVE-2014-1929 · CVE Program
- CVE-2014-1929 · NVD
- FIRST EPSS
- GHSA-vcr5-xr9h-mvc5 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-1929 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences