BuildTrigger in Jenkins before 1.551 and LTS before 1.532.2 allows remote authenticated…
Priority LOW 33CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
BuildTrigger in Jenkins before 1.551 and LTS before 1.532.2 allows remote authenticated users to bypass access restrictions and execute arbitrary jobs by configuring a job to trigger another job. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7330.
Why it matters now
EPSS 0.01844 79th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 1.551, 1.532.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.533 to before 1.551 | 1.551 | Patch available | GHSA-7fpg-pp3m-h22f |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.532.2 | 1.532.2 | Patch available | GHSA-7fpg-pp3m-h22f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.533 to before 1.551 Fixed in 1.551 Patch available GHSA-7fpg-pp3m-h22f
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.532.2 Fixed in 1.532.2 Patch available GHSA-7fpg-pp3m-h22f
Remediation
- Fix · GHSA-7fpg-pp3m-h22f org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.551 Advisory →
- Fix · GHSA-7fpg-pp3m-h22f org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.532.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-2058
- 2026-10-03 Alias added: GHSA-7fpg-pp3m-h22f
References
Advisory 2
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2014-2058 · CVE Program
- CVE-2014-2058 · NVD
- FIRST EPSS
- GHSA-7fpg-pp3m-h22f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences