Read the docs
TI-2014-01628 Aliases CVE-2014-2067GHSA-vj6q-v2h7-6q5m

Cross-site scripting (XSS) vulnerability in java/hudson/model/Cause.java in Jenkins…

Priority LOW 20CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Partial Red Hat: 1 fixed, 1 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in java/hudson/model/Cause.java in Jenkins before 1.551 and LTS before 1.532.2 allows remote authenticated users to inject arbitrary web script or HTML via a "remote cause note."

Why it matters now

EPSS 0.01407 72nd percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 1.551, 1.532.2Red Hat: 1 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)1.533 to before 1.5511.551Patch availableGHSA-vj6q-v2h7-6q5m
—org.jenkins-ci.main:jenkins-core (Maven)before 1.532.21.532.2Patch availableGHSA-vj6q-v2h7-6q5m
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.533 to before 1.551 Fixed in 1.551 Patch available GHSA-vj6q-v2h7-6q5m
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.532.2 Fixed in 1.532.2 Patch available GHSA-vj6q-v2h7-6q5m

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*up to 1.550VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 1.532.1VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 1.550 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 1.532.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-vj6q-v2h7-6q5m org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.551 Advisory →
  • Fix · GHSA-vj6q-v2h7-6q5m org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.532.2 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenShift Enterprise 1AffectedNo fix planned: Will not fix
RHOSE Node 2.1Fixed—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-2067
  2. 2026-10-03 Alias added: GHSA-vj6q-v2h7-6q5m

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources