Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x…
Priority LOW 30CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-22 and the CVSS impact.
Summary
Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.
Why it matters now
EPSS 0.08881 95th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD and the CNA
Fix Partial cobbler (PyPI): 2.6.4, 2.4.7Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cobbler (PyPI) | 2.6.0 to before 2.6.4 | 2.6.4 | Patch available | GHSA-xc7w-jvhx-p6q9 |
| — | cobbler (PyPI) | 2.4.0 to before 2.4.7 | 2.4.7 | Patch available | GHSA-xc7w-jvhx-p6q9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cobbler (PyPI) Vendor— Affected 2.6.0 to before 2.6.4 Fixed in 2.6.4 Patch available GHSA-xc7w-jvhx-p6q9
- cobbler (PyPI) Vendor— Affected 2.4.0 to before 2.4.7 Fixed in 2.4.7 Patch available GHSA-xc7w-jvhx-p6q9
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cobblerd:cobbler:2.4.0:-:*:*:*:*:*:* | 2.4.0 | Vulnerable | Cobblerd |
| cpe:2.3:a:cobblerd:cobbler:2.4.0:1:*:*:*:*:*:* | 2.4.0 1 | Vulnerable | Cobblerd |
| cpe:2.3:a:cobblerd:cobbler:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | Cobblerd |
| cpe:2.3:a:cobblerd:cobbler:2.4.2:*:*:*:*:*:*:* | 2.4.2 | Vulnerable | Cobblerd |
| cpe:2.3:a:cobblerd:cobbler:2.4.3:*:*:*:*:*:*:* | 2.4.3 | Vulnerable | Cobblerd |
| cpe:2.3:a:cobblerd:cobbler:2.4.4:*:*:*:*:*:*:* | 2.4.4 | Vulnerable | Cobblerd |
| cpe:2.3:a:cobblerd:cobbler:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Cobblerd |
- cpe:2.3:a:cobblerd:cobbler:2.4.0:-:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Cobblerd
- cpe:2.3:a:cobblerd:cobbler:2.4.0:1:*:*:*:*:*:* Versions 2.4.0 1 Vulnerable ·Cobblerd
- cpe:2.3:a:cobblerd:cobbler:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·Cobblerd
- cpe:2.3:a:cobblerd:cobbler:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·Cobblerd
- cpe:2.3:a:cobblerd:cobbler:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Cobblerd
- cpe:2.3:a:cobblerd:cobbler:2.4.4:*:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Cobblerd
- cpe:2.3:a:cobblerd:cobbler:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Cobblerd
Remediation
- Fix · GHSA-xc7w-jvhx-p6q9 cobbler (PyPI) Fixed in 2.6.4 Advisory →
- Fix · GHSA-xc7w-jvhx-p6q9 cobbler (PyPI) Fixed in 2.4.7 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 5 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3225
- 2026-10-03 Alias added: GHSA-xc7w-jvhx-p6q9
References
Exploit 3
Other 7
- [oss-security] 20140508 Re: CVE Request - Local File inclusion in Cobbler
- https://github.com/cobbler/cobbler/issues/939
- 106759
- [oss-security] 20140508 CVE Request - Local File inclusion in Cobbler
- https://github.com/cobbler/cobbler/commit/8232c0e88ec7382d3f8d3bf48c81a4a91ac4325d
- https://github.com/cobbler/cobbler/commit/f757e3096fcd32397609ca38efb01f19d16dd634
- https://github.com/cobbler/cobbler
More Cobblerd Cobbler vulnerabilities
- TI-2018-15871 Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection… CVSS 3.0CRITICAL 9.8
- TI-2011-04262 cobbler: Web interface lacks CSRF protection when using Django framework CVSS 3.1HIGH 8.8
- TI-2011-04264 cobbler has local privilege escalation via the use of insecure location for PYTHON_EGG_CACHE CVSS 3.1HIGH 7.8
- TI-2018-15870 Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2014-3225 · CVE Program
- CVE-2014-3225 · NVD
- FIRST EPSS
- GHSA-xc7w-jvhx-p6q9 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3225 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences