Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cobbler (PyPI) | before 3.0.0 | 3.0.0 | Patch available | GHSA-f88q-22g8-frcg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cobbler (PyPI) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-f88q-22g8-frcg
Remediation
- Fix · GHSA-f88q-22g8-frcg cobbler (PyPI) Fixed in 3.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 5 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000226
- 2026-10-03 Alias added: GHSA-f88q-22g8-frcg
References
Advisory 3
More Cobblerd Cobbler vulnerabilities
- TI-2011-04262 cobbler: Web interface lacks CSRF protection when using Django framework CVSS 3.1HIGH 8.8
- TI-2011-04264 cobbler has local privilege escalation via the use of insecure location for PYTHON_EGG_CACHE CVSS 3.1HIGH 7.8
- TI-2018-15870 Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection… CVSS 3.0MEDIUM 6.1
- TI-2014-02584 Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2018-1000226 · CVE Program
- CVE-2018-1000226 · NVD
- FIRST EPSS
- GHSA-f88q-22g8-frcg · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000226 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences