The LDAPLoginModule implementation in the Java Authentication and Authorization Service…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Partial Red Hat: 5 fixed, 2 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.
Summary
The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind. NOTE: this identifier has been SPLIT per ADT2 due to different vulnerability types. See CVE-2015-6524 for the use of wildcard operators in usernames.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.activemq:activemq-broker (Maven) | 5.0.0 to before 5.10.1 | 5.10.1 | Patch available | GHSA-72m6-23ff-7q26 |
| — | org.apache.activemq:activemq-jaas (Maven) | 5.0.0 to before 5.10.1 | 5.10.1 | Patch available | GHSA-72m6-23ff-7q26 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.activemq:activemq-broker (Maven) Vendor— Affected 5.0.0 to before 5.10.1 Fixed in 5.10.1 Patch available GHSA-72m6-23ff-7q26
- org.apache.activemq:activemq-jaas (Maven) Vendor— Affected 5.0.0 to before 5.10.1 Fixed in 5.10.1 Patch available GHSA-72m6-23ff-7q26
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* | 5.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* | 5.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* | 5.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* | 5.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* | 5.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* | 5.3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* | 5.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* | 5.4.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* | 5.4.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.3:*:*:*:*:*:*:* | 5.4.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* Versions 5.3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* Versions 5.4.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* Versions 5.4.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.3:*:*:*:*:*:*:* Versions 5.4.3 Vulnerable ·Apache
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* | 5.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* | 5.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* | 5.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.7.0:*:*:*:*:*:*:* | 5.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.8.0:*:*:*:*:*:*:* | 5.8.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.9.0:*:*:*:*:*:*:* | 5.9.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.9.1:*:*:*:*:*:*:* | 5.9.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.10.0:*:*:*:*:*:*:* | 5.10.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* Versions 5.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* Versions 5.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* Versions 5.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.7.0:*:*:*:*:*:*:* Versions 5.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.8.0:*:*:*:*:*:*:* Versions 5.8.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.9.0:*:*:*:*:*:*:* Versions 5.9.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.9.1:*:*:*:*:*:*:* Versions 5.9.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.10.0:*:*:*:*:*:*:* Versions 5.10.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-72m6-23ff-7q26 org.apache.activemq:activemq-broker (Maven) Fixed in 5.10.1 Advisory →
- Fix · GHSA-72m6-23ff-7q26 org.apache.activemq:activemq-jaas (Maven) Fixed in 5.10.1 Advisory →
Red Hat 2 advisories
- RHSA-2015:0137 Released 2015-02-05 · Red Hat rating ImportantRed Hat JBoss Fuse/A-MQ 6.1.0 security and bug fix update
- Red Hat JBoss A-MQ 6.1
- Red Hat JBoss Fuse 6.1
- RHSA-2015:0138 Released 2015-02-05 · Red Hat rating ImportantFuse ESB Enterprise/Fuse MQ Enterprise 7.1.0 security update
- Fuse ESB Enterprise 7.1.0
- Fuse MQ Enterprise 7.1.0
- Fuse Management Console 7.1.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
| Fuse ESB Enterprise 7.1.0 | Fixed | RHSA-2015:0138 |
| Fuse MQ Enterprise 7.1.0 | Fixed | RHSA-2015:0138 |
| Fuse Management Console 7.1.0 | Fixed | RHSA-2015:0138 |
| Red Hat JBoss A-MQ 6.1 | Fixed | RHSA-2015:0137 |
| Red Hat JBoss Fuse 6.1 | Fixed | RHSA-2015:0137 |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3612
- 2026-10-03 Alias added: GHSA-72m6-23ff-7q26
References
Advisory 4
Other 6
- [oss-security] 20150205 [ANNOUNCE] CVE-2014-3600, CVE-2014-3612 and CVE-2014-8110 - Apache ActiveMQ vulnerabilities
- [activemq-commits] 20190327 svn commit: r1042639 - in /websites/production/activemq/content/activemq-website: ./ projects/artemis/download/ projects/classic/download/ projects/cms/download/ security-advisories.data/
- https://github.com/apache/activemq/commit/22f2f3dde757d31307da772d579815c1d169bc39
- https://github.com/apache/activemq
- https://issues.apache.org/jira/browse/AMQ-5345
- https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2@%3Ccommits.activemq.apache.org%3E
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-3612 · CVE Program
- CVE-2014-3612 · NVD
- FIRST EPSS
- GHSA-72m6-23ff-7q26 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3612 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences