Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.
Why it matters now
EPSS 0.04702 91st percentileScored 2026-11-07
Fix Partial org.apache.solr:solr (Maven): 4.10.3Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.solr:solr (Maven) | 4.0.0 to before 4.10.3 | 4.10.3 | Patch available | GHSA-wgw2-gw4v-9w4j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.solr:solr (Maven) Vendor— Affected 4.0.0 to before 4.10.3 Fixed in 4.10.3 Patch available GHSA-wgw2-gw4v-9w4j
CPE configurations NVD · 23
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:solr:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.0.0:alpha:*:*:*:*:*:* | 4.0.0 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.0.0:beta:*:*:*:*:*:* | 4.0.0 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.2.0:*:*:*:*:*:*:* | 4.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.2.1:*:*:*:*:*:*:* | 4.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.3.0:*:*:*:*:*:*:* | 4.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.3.1:*:*:*:*:*:*:* | 4.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.4.0:*:*:*:*:*:*:* | 4.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.5.0:*:*:*:*:*:*:* | 4.5.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:solr:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.0.0:alpha:*:*:*:*:*:* Versions 4.0.0 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.0.0:beta:*:*:*:*:*:* Versions 4.0.0 beta Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.2.1:*:*:*:*:*:*:* Versions 4.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.3.0:*:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.3.1:*:*:*:*:*:*:* Versions 4.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.4.0:*:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.5.0:*:*:*:*:*:*:* Versions 4.5.0 Vulnerable ·Apache
Show 13 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:solr:4.5.1:*:*:*:*:*:*:* | 4.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.6.0:*:*:*:*:*:*:* | 4.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.6.1:*:*:*:*:*:*:* | 4.6.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.7.0:*:*:*:*:*:*:* | 4.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.7.1:*:*:*:*:*:*:* | 4.7.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.7.2:*:*:*:*:*:*:* | 4.7.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.8.0:*:*:*:*:*:*:* | 4.8.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.8.1:*:*:*:*:*:*:* | 4.8.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.9.0:*:*:*:*:*:*:* | 4.9.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.9.1:*:*:*:*:*:*:* | 4.9.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.10.0:*:*:*:*:*:*:* | 4.10.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.10.1:*:*:*:*:*:*:* | 4.10.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:solr:4.10.2:*:*:*:*:*:*:* | 4.10.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:solr:4.5.1:*:*:*:*:*:*:* Versions 4.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.6.0:*:*:*:*:*:*:* Versions 4.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.6.1:*:*:*:*:*:*:* Versions 4.6.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.7.0:*:*:*:*:*:*:* Versions 4.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.7.1:*:*:*:*:*:*:* Versions 4.7.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.7.2:*:*:*:*:*:*:* Versions 4.7.2 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.8.0:*:*:*:*:*:*:* Versions 4.8.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.8.1:*:*:*:*:*:*:* Versions 4.8.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.9.0:*:*:*:*:*:*:* Versions 4.9.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.9.1:*:*:*:*:*:*:* Versions 4.9.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.10.0:*:*:*:*:*:*:* Versions 4.10.0 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.10.1:*:*:*:*:*:*:* Versions 4.10.1 Vulnerable ·Apache
- cpe:2.3:a:apache:solr:4.10.2:*:*:*:*:*:*:* Versions 4.10.2 Vulnerable ·Apache
Remediation
- Fix · GHSA-wgw2-gw4v-9w4j org.apache.solr:solr (Maven) Fixed in 4.10.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Data Grid 6 | Affected | No fix planned: Will not fix |
| Red Hat JBoss Data Virtualization 6 | Affected | No fix planned: Will not fix |
| Red Hat JBoss Fuse Service Works 6 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3628
- 2026-10-03 Alias added: GHSA-wgw2-gw4v-9w4j
References
More Apache Solr vulnerabilities
- TI-2024-30303 Apache Solr: Authentication bypass possible using a fake URL Path ending CVSS 3.1CRITICAL 9.8
- TI-2019-13101 Injection in Apache Solr KEVCVSS 3.1HIGH 7.5
- TI-2019-00170 Code injection in Apache Solr KEVCVSS 3.1HIGH 7.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2021-09240 SSRF vulnerability with the Replication handler CVSS 3.1CRITICAL 9.8
- TI-2017-09354 XML external entity injection in Apache Solr before 7.1 with Apache Lucene before 7.1 CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-3628 · CVE Program
- CVE-2014-3628 · NVD
- FIRST EPSS
- GHSA-wgw2-gw4v-9w4j · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3628 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences