Cross-site scripting (XSS) vulnerability in the Monitoring plugin before 1.53.0 for…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.0184 79th percentileScored 2026-11-07
Fix Partial org.jvnet.hudson.plugins:monitoring (Maven): 1.53.0Red Hat: 1 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jvnet.hudson.plugins:monitoring (Maven) | before 1.53.0 | 1.53.0 | Patch available | GHSA-ghjw-fc9q-jj8c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jvnet.hudson.plugins:monitoring (Maven) Vendor— Affected before 1.53.0 Fixed in 1.53.0 Patch available GHSA-ghjw-fc9q-jj8c
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins-ci:monitoring_plugin:*:*:*:*:*:cloudbees_jenkins:*:* | up to 1.52.1 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.40.0:*:*:*:*:cloudbees_jenkins:*:* | 1.40.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.41.0:*:*:*:*:cloudbees_jenkins:*:* | 1.41.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.42.0:*:*:*:*:cloudbees_jenkins:*:* | 1.42.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.43.0:*:*:*:*:cloudbees_jenkins:*:* | 1.43.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.44.0:*:*:*:*:cloudbees_jenkins:*:* | 1.44.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.45.0:*:*:*:*:cloudbees_jenkins:*:* | 1.45.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.46.0:*:*:*:*:cloudbees_jenkins:*:* | 1.46.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.47.0:*:*:*:*:cloudbees_jenkins:*:* | 1.47.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.48.0:*:*:*:*:cloudbees_jenkins:*:* | 1.48.0 | Vulnerable | Jenkins-ci |
- cpe:2.3:a:jenkins-ci:monitoring_plugin:*:*:*:*:*:cloudbees_jenkins:*:* Versions up to 1.52.1 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.40.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.40.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.41.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.41.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.42.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.42.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.43.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.43.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.44.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.44.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.45.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.45.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.46.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.46.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.47.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.47.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.48.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.48.0 Vulnerable ·Jenkins-ci
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.49.0:*:*:*:*:cloudbees_jenkins:*:* | 1.49.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.50.0:*:*:*:*:cloudbees_jenkins:*:* | 1.50.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.51.0:*:*:*:*:cloudbees_jenkins:*:* | 1.51.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.52.0:*:*:*:*:cloudbees_jenkins:*:* | 1.52.0 | Vulnerable | Jenkins-ci |
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.49.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.49.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.50.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.50.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.51.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.51.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.52.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.52.0 Vulnerable ·Jenkins-ci
Remediation
- Fix · GHSA-ghjw-fc9q-jj8c org.jvnet.hudson.plugins:monitoring (Maven) Fixed in 1.53.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| RHOSE Node 2.1 | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3678
- 2026-10-03 Alias added: GHSA-ghjw-fc9q-jj8c
References
Other 7
- https://wiki.jenkins-ci.org/display/JENKINS/Monitoring
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-10-01
- https://github.com/jenkinsci/monitoring-plugin/commit/f0f6aeef2032696c97d4b015dd51fa2b841b0473
- https://access.redhat.com/errata/RHBA-2014:1630
- https://access.redhat.com/security/cve/CVE-2014-3678
- https://bugzilla.redhat.com/show_bug.cgi?id=1147760
- https://github.com/jenkinsci/monitoring-plugin
More Jenkins-ci Monitoring Plugin vulnerabilities
- TI-2014-02996 The Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to obtain… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2014-3678 · CVE Program
- CVE-2014-3678 · NVD
- FIRST EPSS
- GHSA-ghjw-fc9q-jj8c · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3678 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences