The Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to obtain…
Priority LOW 26CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-284.
Summary
The Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to obtain sensitive information by accessing unspecified pages.
Why it matters now
EPSS 0.01781 78th percentileScored 2026-11-07
Fix Partial org.jvnet.hudson.plugins:monitoring (Maven): 1.53.0Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jvnet.hudson.plugins:monitoring (Maven) | before 1.53.0 | 1.53.0 | Patch available | GHSA-qwc3-p5pc-q93h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jvnet.hudson.plugins:monitoring (Maven) Vendor— Affected before 1.53.0 Fixed in 1.53.0 Patch available GHSA-qwc3-p5pc-q93h
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins-ci:monitoring_plugin:*:*:*:*:*:cloudbees_jenkins:*:* | up to 1.52.1 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.40.0:*:*:*:*:cloudbees_jenkins:*:* | 1.40.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.41.0:*:*:*:*:cloudbees_jenkins:*:* | 1.41.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.42.0:*:*:*:*:cloudbees_jenkins:*:* | 1.42.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.43.0:*:*:*:*:cloudbees_jenkins:*:* | 1.43.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.44.0:*:*:*:*:cloudbees_jenkins:*:* | 1.44.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.45.0:*:*:*:*:cloudbees_jenkins:*:* | 1.45.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.46.0:*:*:*:*:cloudbees_jenkins:*:* | 1.46.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.47.0:*:*:*:*:cloudbees_jenkins:*:* | 1.47.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.48.0:*:*:*:*:cloudbees_jenkins:*:* | 1.48.0 | Vulnerable | Jenkins-ci |
- cpe:2.3:a:jenkins-ci:monitoring_plugin:*:*:*:*:*:cloudbees_jenkins:*:* Versions up to 1.52.1 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.40.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.40.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.41.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.41.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.42.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.42.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.43.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.43.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.44.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.44.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.45.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.45.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.46.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.46.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.47.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.47.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.48.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.48.0 Vulnerable ·Jenkins-ci
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.49.0:*:*:*:*:cloudbees_jenkins:*:* | 1.49.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.50.0:*:*:*:*:cloudbees_jenkins:*:* | 1.50.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.51.0:*:*:*:*:cloudbees_jenkins:*:* | 1.51.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:monitoring_plugin:1.52.0:*:*:*:*:cloudbees_jenkins:*:* | 1.52.0 | Vulnerable | Jenkins-ci |
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.49.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.49.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.50.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.50.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.51.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.51.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:monitoring_plugin:1.52.0:*:*:*:*:cloudbees_jenkins:*:* Versions 1.52.0 Vulnerable ·Jenkins-ci
Remediation
- Fix · GHSA-qwc3-p5pc-q93h org.jvnet.hudson.plugins:monitoring (Maven) Fixed in 1.53.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Enterprise 2 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3679
- 2026-10-03 Alias added: GHSA-qwc3-p5pc-q93h
References
Advisory 3
More Jenkins-ci Monitoring Plugin vulnerabilities
- TI-2014-02995 Cross-site scripting (XSS) vulnerability in the Monitoring plugin before 1.53.0 for… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2014-3679 · CVE Program
- CVE-2014-3679 · NVD
- FIRST EPSS
- GHSA-qwc3-p5pc-q93h · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3679 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences