Read the docs
TI-2014-03159 Aliases CVE-2014-3885GHSA-q542-vr4j-4x88

Cross-site scripting (XSS) vulnerability in Webmin before 1.690 allows remote…

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
No fix listed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in Webmin before 1.690 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors. NOTE: this might overlap CVE-2014-3924.

Why it matters now

EPSS 0.00931 60th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:webmin:webmin:*:*:*:*:*:*:*:*up to 1.680VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.600:*:*:*:*:*:*:*1.600VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.610:*:*:*:*:*:*:*1.610VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.620:*:*:*:*:*:*:*1.620VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.630:*:*:*:*:*:*:*1.630VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.640:*:*:*:*:*:*:*1.640VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.650:*:*:*:*:*:*:*1.650VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.660:*:*:*:*:*:*:*1.660VulnerableWebmin
cpe:2.3:a:webmin:webmin:1.670:*:*:*:*:*:*:*1.670VulnerableWebmin
  • cpe:2.3:a:webmin:webmin:*:*:*:*:*:*:*:* Versions up to 1.680 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.600:*:*:*:*:*:*:* Versions 1.600 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.610:*:*:*:*:*:*:* Versions 1.610 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.620:*:*:*:*:*:*:* Versions 1.620 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.630:*:*:*:*:*:*:* Versions 1.630 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.640:*:*:*:*:*:*:* Versions 1.640 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.650:*:*:*:*:*:*:* Versions 1.650 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.660:*:*:*:*:*:*:* Versions 1.660 Vulnerable ·Webmin
  • cpe:2.3:a:webmin:webmin:1.670:*:*:*:*:*:*:* Versions 1.670 Vulnerable ·Webmin

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-3885
  2. 2026-10-03 Alias added: GHSA-q542-vr4j-4x88

References

  • TI-2019-11278 An issue was discovered in Webmin <=1.920. KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-16770 software/apt-lib.pl in Webmin before 1.997 lacks HTML escaping for a UI command. CVSS 3.1CRITICAL 9.8
  • TI-2022-00731 Improper Access Control to Remote Code Execution in webmin/webmin CVSS 3.1HIGH 8.8
  • TI-2019-09619 In Webmin through 1.910, any user authorized to the "Package Updates" module can execute… CVSS 3.0HIGH 8.8
  • TI-2021-11777 Webmin 1.973 is affected by reflected Cross Site Scripting (XSS) to achieve Remote… CVSS 3.1CRITICAL 9.6
  • TI-2024-11888 OS command injection in Webmin CVSS 3.1HIGH 8.8
See all 95 →

Sources