Read the docs
TI-2014-03257 Aliases CVE-2014-3994GHSA-w7rq-8f2g-jvqr

Cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets…

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django, as used in Review Board, allows remote attackers to inject arbitrary web script or HTML via a JSON object, as demonstrated by the name field when changing a user name.

Why it matters now

EPSS 0.02403 84th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Djblets (PyPI): 0.7.30, 0.8.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—Djblets (PyPI)before 0.7.300.7.30Patch availableGHSA-w7rq-8f2g-jvqr
—Djblets (PyPI)0.8 to before 0.8.30.8.3Patch availableGHSA-w7rq-8f2g-jvqr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • Djblets (PyPI) Vendor— Affected before 0.7.30 Fixed in 0.7.30 Patch available GHSA-w7rq-8f2g-jvqr
  • Djblets (PyPI) Vendor— Affected 0.8 to before 0.8.3 Fixed in 0.8.3 Patch available GHSA-w7rq-8f2g-jvqr

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:reviewboard:djblets:*:*:*:*:*:*:*:*up to 0.7.29VulnerableReview Board
cpe:2.3:a:reviewboard:djblets:0.7.27:*:*:*:*:*:*:*0.7.27VulnerableReview Board
cpe:2.3:a:reviewboard:djblets:0.7.28:*:*:*:*:*:*:*0.7.28VulnerableReview Board
cpe:2.3:a:reviewboard:djblets:0.8.1:*:*:*:*:*:*:*0.8.1VulnerableReview Board
cpe:2.3:a:reviewboard:djblets:0.8.2:*:*:*:*:*:*:*0.8.2VulnerableReview Board
cpe:2.3:a:reviewboard:reviewboard:-:*:*:*:*:*:*:*not specified by NVDVulnerableReview Board
  • cpe:2.3:a:reviewboard:djblets:*:*:*:*:*:*:*:* Versions up to 0.7.29 Vulnerable ·Review Board
  • cpe:2.3:a:reviewboard:djblets:0.7.27:*:*:*:*:*:*:* Versions 0.7.27 Vulnerable ·Review Board
  • cpe:2.3:a:reviewboard:djblets:0.7.28:*:*:*:*:*:*:* Versions 0.7.28 Vulnerable ·Review Board
  • cpe:2.3:a:reviewboard:djblets:0.8.1:*:*:*:*:*:*:* Versions 0.8.1 Vulnerable ·Review Board
  • cpe:2.3:a:reviewboard:djblets:0.8.2:*:*:*:*:*:*:* Versions 0.8.2 Vulnerable ·Review Board
  • cpe:2.3:a:reviewboard:reviewboard:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Review Board

Remediation

  • Fix · GHSA-w7rq-8f2g-jvqr Djblets (PyPI) Fixed in 0.7.30 Advisory →
  • Fix · GHSA-w7rq-8f2g-jvqr Djblets (PyPI) Fixed in 0.8.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-3994
  2. 2026-10-03 Alias added: GHSA-w7rq-8f2g-jvqr

References

  • TI-2013-03864 Improper input validation in Python Software Foundation; Beanbag Djblets CVSS 3.1CRITICAL 9.8
  • TI-2014-03258 Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in… CVSS 2.0MEDIUM 4.3

Sources