Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
Why it matters now
EPSS 0.02093 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Djblets (PyPI): 0.7.30, 0.8.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Djblets (PyPI) | before 0.7.30 | 0.7.30 | Patch available | GHSA-4xf6-xr96-7vmp |
| — | Djblets (PyPI) | 0.8 to before 0.8.3 | 0.8.3 | Patch available | GHSA-4xf6-xr96-7vmp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Djblets (PyPI) Vendor— Affected before 0.7.30 Fixed in 0.7.30 Patch available GHSA-4xf6-xr96-7vmp
- Djblets (PyPI) Vendor— Affected 0.8 to before 0.8.3 Fixed in 0.8.3 Patch available GHSA-4xf6-xr96-7vmp
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:reviewboard:djblets:*:*:*:*:*:*:*:* | up to 0.7.29 | Vulnerable | Review Board |
| cpe:2.3:a:reviewboard:djblets:0.7.27:*:*:*:*:*:*:* | 0.7.27 | Vulnerable | Review Board |
| cpe:2.3:a:reviewboard:djblets:0.7.28:*:*:*:*:*:*:* | 0.7.28 | Vulnerable | Review Board |
| cpe:2.3:a:reviewboard:djblets:0.8.1:*:*:*:*:*:*:* | 0.8.1 | Vulnerable | Review Board |
| cpe:2.3:a:reviewboard:djblets:0.8.2:*:*:*:*:*:*:* | 0.8.2 | Vulnerable | Review Board |
- cpe:2.3:a:reviewboard:djblets:*:*:*:*:*:*:*:* Versions up to 0.7.29 Vulnerable ·Review Board
- cpe:2.3:a:reviewboard:djblets:0.7.27:*:*:*:*:*:*:* Versions 0.7.27 Vulnerable ·Review Board
- cpe:2.3:a:reviewboard:djblets:0.7.28:*:*:*:*:*:*:* Versions 0.7.28 Vulnerable ·Review Board
- cpe:2.3:a:reviewboard:djblets:0.8.1:*:*:*:*:*:*:* Versions 0.8.1 Vulnerable ·Review Board
- cpe:2.3:a:reviewboard:djblets:0.8.2:*:*:*:*:*:*:* Versions 0.8.2 Vulnerable ·Review Board
Remediation
- Fix · GHSA-4xf6-xr96-7vmp Djblets (PyPI) Fixed in 0.7.30 Advisory →
- Fix · GHSA-4xf6-xr96-7vmp Djblets (PyPI) Fixed in 0.8.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3995
- 2026-10-03 Alias added: GHSA-4xf6-xr96-7vmp
References
Patch 2
Other 6
- [oss-security] 20140606 Requesting CVEs issued for two XSS vulnerabilities in Djblets (a set of Django helpers)
- [oss-security] 20140606 Re: Requesting CVEs issued for two XSS vulnerabilities in Djblets (a set of Django helpers)
- https://github.com/djblets/djblets
- https://github.com/pypa/advisory-database/tree/main/vulns/djblets/PYSEC-2014-79.yaml
- https://web.archive.org/web/20140702014704/http://seclists.org/oss-sec/2014/q2/498
- https://web.archive.org/web/20140702025724/http://seclists.org/oss-sec/2014/q2/494
More Review Board Djblets vulnerabilities
- TI-2013-03864 Improper input validation in Python Software Foundation; Beanbag Djblets CVSS 3.1CRITICAL 9.8
- TI-2014-03257 Cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2014-3995 · CVE Program
- CVE-2014-3995 · NVD
- FIRST EPSS
- GHSA-4xf6-xr96-7vmp · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3995 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences