Multiple cross-site scripting (XSS) vulnerabilities in the respond_error function in…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the respond_error function in routing.py in Eugene Pankov Ajenti before 1.2.21.7 allow remote attackers to inject arbitrary web script or HTML via the PATH_INFO to (1) resources.js or (2) resources.css in ajenti:static/, related to the traceback page.
Why it matters now
EPSS 0.02292 83rd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed ajenti (PyPI): 1.2.21.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ajenti (PyPI) | before 1.2.21.7 | 1.2.21.7 | Patch available | GHSA-2ch8-f849-pjg3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ajenti (PyPI) Vendor— Affected before 1.2.21.7 Fixed in 1.2.21.7 Patch available GHSA-2ch8-f849-pjg3
CPE configurations NVD · 22
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ajenti:ajenti:*:*:*:*:*:*:*:* | up to 1.2.21 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.1:*:*:*:*:*:*:* | 1.2.1 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.2:*:*:*:*:*:*:* | 1.2.2 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.3:*:*:*:*:*:*:* | 1.2.3 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.4:*:*:*:*:*:*:* | 1.2.4 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.5:*:*:*:*:*:*:* | 1.2.5 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.6:*:*:*:*:*:*:* | 1.2.6 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.7:*:*:*:*:*:*:* | 1.2.7 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.8:*:*:*:*:*:*:* | 1.2.8 | Vulnerable | ajenti |
- cpe:2.3:a:ajenti:ajenti:*:*:*:*:*:*:*:* Versions up to 1.2.21 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.2:*:*:*:*:*:*:* Versions 1.2.2 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.3:*:*:*:*:*:*:* Versions 1.2.3 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.4:*:*:*:*:*:*:* Versions 1.2.4 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.5:*:*:*:*:*:*:* Versions 1.2.5 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.6:*:*:*:*:*:*:* Versions 1.2.6 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.7:*:*:*:*:*:*:* Versions 1.2.7 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.8:*:*:*:*:*:*:* Versions 1.2.8 Vulnerable ·ajenti
Show 12 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ajenti:ajenti:1.2.9:*:*:*:*:*:*:* | 1.2.9 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.10:*:*:*:*:*:*:* | 1.2.10 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.11.2:*:*:*:*:*:*:* | 1.2.11.2 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.12:*:*:*:*:*:*:* | 1.2.12 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.13:*:*:*:*:*:*:* | 1.2.13 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.14:*:*:*:*:*:*:* | 1.2.14 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.15:*:*:*:*:*:*:* | 1.2.15 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.16:*:*:*:*:*:*:* | 1.2.16 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.17:*:*:*:*:*:*:* | 1.2.17 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.18:*:*:*:*:*:*:* | 1.2.18 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.19:*:*:*:*:*:*:* | 1.2.19 | Vulnerable | ajenti |
| cpe:2.3:a:ajenti:ajenti:1.2.20:*:*:*:*:*:*:* | 1.2.20 | Vulnerable | ajenti |
- cpe:2.3:a:ajenti:ajenti:1.2.9:*:*:*:*:*:*:* Versions 1.2.9 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.10:*:*:*:*:*:*:* Versions 1.2.10 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.11.2:*:*:*:*:*:*:* Versions 1.2.11.2 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.12:*:*:*:*:*:*:* Versions 1.2.12 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.13:*:*:*:*:*:*:* Versions 1.2.13 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.14:*:*:*:*:*:*:* Versions 1.2.14 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.15:*:*:*:*:*:*:* Versions 1.2.15 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.16:*:*:*:*:*:*:* Versions 1.2.16 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.17:*:*:*:*:*:*:* Versions 1.2.17 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.18:*:*:*:*:*:*:* Versions 1.2.18 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.19:*:*:*:*:*:*:* Versions 1.2.19 Vulnerable ·ajenti
- cpe:2.3:a:ajenti:ajenti:1.2.20:*:*:*:*:*:*:* Versions 1.2.20 Vulnerable ·ajenti
Remediation
- Fix · GHSA-2ch8-f849-pjg3 ajenti (PyPI) Fixed in 1.2.21.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-4301
- 2026-10-03 Alias added: GHSA-2ch8-f849-pjg3
References
Exploit 2
More Ajenti vulnerabilities
- TI-2019-15206 ajenti API privileges management CVSS 3.1HIGH 8.8
- TI-2026-22317 Ajenti has a potential Remote Code Execution CVSS 4.0HIGH 8.1
- TI-2018-15737 Ajenti version version 2 contains a Cross ite Request Forgery (CSRF) vulnerability in the… CVSS 3.0HIGH 8.8
- TI-2018-15779 Ajenti version 2 contains an Information Disclosure vulnerability in Line 176 of the code… CVSS 3.0HIGH 7.5
- TI-2018-15736 Ajenti version version 2 contains a Input Validation vulnerability in ID string on… CVSS 3.0HIGH 7.5
- TI-2026-27329 Ajenti has an authorization bypass during custom package installation CVSS 4.0HIGH 7.2
Sources
- CVE-2014-4301 · CVE Program
- CVE-2014-4301 · NVD
- FIRST EPSS
- GHSA-2ch8-f849-pjg3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences