Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x…
Priority LOW 19CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.
Why it matters now
EPSS 0.01016 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.1.14.3, 4.2.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | 4.1.0 to before 4.1.14.3 | 4.1.14.3 | Patch available | GHSA-q586-xpwr-jc3j |
| — | phpmyadmin/phpmyadmin (Packagist) | 4.2.0 to before 4.2.7.1 | 4.2.7.1 | Patch available | GHSA-q586-xpwr-jc3j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.1.0 to before 4.1.14.3 Fixed in 4.1.14.3 Patch available GHSA-q586-xpwr-jc3j
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.2.0 to before 4.2.7.1 Fixed in 4.2.7.1 Patch available GHSA-q586-xpwr-jc3j
CPE configurations NVD · 27
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.2:*:*:*:*:*:*:* | 4.1.2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.3:*:*:*:*:*:*:* | 4.1.3 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.4:*:*:*:*:*:*:* | 4.1.4 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.5:*:*:*:*:*:*:* | 4.1.5 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.6:*:*:*:*:*:*:* | 4.1.6 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.7:*:*:*:*:*:*:* | 4.1.7 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.8:*:*:*:*:*:*:* | 4.1.8 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.9:*:*:*:*:*:*:* | 4.1.9 | Vulnerable | phpMyAdmin |
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.2:*:*:*:*:*:*:* Versions 4.1.2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.3:*:*:*:*:*:*:* Versions 4.1.3 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.4:*:*:*:*:*:*:* Versions 4.1.4 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.5:*:*:*:*:*:*:* Versions 4.1.5 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.6:*:*:*:*:*:*:* Versions 4.1.6 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.7:*:*:*:*:*:*:* Versions 4.1.7 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.8:*:*:*:*:*:*:* Versions 4.1.8 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.9:*:*:*:*:*:*:* Versions 4.1.9 Vulnerable ·phpMyAdmin
Show 17 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.10:*:*:*:*:*:*:* | 4.1.10 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.11:*:*:*:*:*:*:* | 4.1.11 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.12:*:*:*:*:*:*:* | 4.1.12 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.13:*:*:*:*:*:*:* | 4.1.13 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.14:*:*:*:*:*:*:* | 4.1.14 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.14.1:*:*:*:*:*:*:* | 4.1.14.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.14.2:*:*:*:*:*:*:* | 4.1.14.2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.0:*:*:*:*:*:*:* | 4.2.0 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.1:*:*:*:*:*:*:* | 4.2.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.2:*:*:*:*:*:*:* | 4.2.2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.3:*:*:*:*:*:*:* | 4.2.3 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.4:*:*:*:*:*:*:* | 4.2.4 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.5:*:*:*:*:*:*:* | 4.2.5 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.6:*:*:*:*:*:*:* | 4.2.6 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.7:*:*:*:*:*:*:* | 4.2.7 | Vulnerable | phpMyAdmin |
| cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* | 13.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* | 13.2 | Vulnerable | openSUSE |
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.10:*:*:*:*:*:*:* Versions 4.1.10 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.11:*:*:*:*:*:*:* Versions 4.1.11 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.12:*:*:*:*:*:*:* Versions 4.1.12 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.13:*:*:*:*:*:*:* Versions 4.1.13 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.14:*:*:*:*:*:*:* Versions 4.1.14 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.14.1:*:*:*:*:*:*:* Versions 4.1.14.1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.1.14.2:*:*:*:*:*:*:* Versions 4.1.14.2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.1:*:*:*:*:*:*:* Versions 4.2.1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.2:*:*:*:*:*:*:* Versions 4.2.2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.3:*:*:*:*:*:*:* Versions 4.2.3 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.4:*:*:*:*:*:*:* Versions 4.2.4 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.5:*:*:*:*:*:*:* Versions 4.2.5 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.6:*:*:*:*:*:*:* Versions 4.2.6 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.2.7:*:*:*:*:*:*:* Versions 4.2.7 Vulnerable ·phpMyAdmin
- cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-q586-xpwr-jc3j phpmyadmin/phpmyadmin (Packagist) Fixed in 4.1.14.3 Advisory →
- Fix · GHSA-q586-xpwr-jc3j phpmyadmin/phpmyadmin (Packagist) Fixed in 4.2.7.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-5274
- 2026-10-03 Alias added: GHSA-q586-xpwr-jc3j
References
Sources
- CVE-2014-5274 · CVE Program
- CVE-2014-5274 · NVD
- FIRST EPSS
- GHSA-q586-xpwr-jc3j · GitHub Advisory Database · CC BY 4.0
- CVE-2014-5274 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences