Multiple cross-site scripting (XSS) vulnerabilities in the web based administration…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the web based administration console in Apache ActiveMQ 5.x before 5.10.1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.07142 94th percentileScored 2026-11-07
Fix Fixed org.apache.activemq:activemq-client (Maven): 5.10.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.activemq:activemq-client (Maven) | 5.0.0 to before 5.10.1 | 5.10.1 | Patch available | GHSA-9cvr-8xq4-2m73 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.activemq:activemq-client (Maven) Vendor— Affected 5.0.0 to before 5.10.1 Fixed in 5.10.1 Patch available GHSA-9cvr-8xq4-2m73
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* | 5.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* | 5.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* | 5.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* | 5.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* | 5.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* | 5.3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* | 5.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* | 5.4.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* | 5.4.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.4.3:*:*:*:*:*:*:* | 5.4.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* Versions 5.3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* Versions 5.4.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* Versions 5.4.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.4.3:*:*:*:*:*:*:* Versions 5.4.3 Vulnerable ·Apache
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* | 5.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* | 5.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* | 5.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.7.0:*:*:*:*:*:*:* | 5.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.8.0:*:*:*:*:*:*:* | 5.8.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.9.0:*:*:*:*:*:*:* | 5.9.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.9.1:*:*:*:*:*:*:* | 5.9.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.10.0:*:*:*:*:*:*:* | 5.10.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* Versions 5.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.5.1:*:*:*:*:*:*:* Versions 5.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.6.0:*:*:*:*:*:*:* Versions 5.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.7.0:*:*:*:*:*:*:* Versions 5.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.8.0:*:*:*:*:*:*:* Versions 5.8.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.9.0:*:*:*:*:*:*:* Versions 5.9.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.9.1:*:*:*:*:*:*:* Versions 5.9.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.10.0:*:*:*:*:*:*:* Versions 5.10.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-9cvr-8xq4-2m73 org.apache.activemq:activemq-client (Maven) Fixed in 5.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-8110
- 2026-10-03 Alias added: GHSA-9cvr-8xq4-2m73
References
Advisory 2
Other 9
- [oss-security] 20150205 [ANNOUNCE] CVE-2014-3600, CVE-2014-3612 and CVE-2014-8110 - Apache ActiveMQ vulnerabilities
- [activemq-commits] 20190327 svn commit: r1042639 - in /websites/production/activemq/content/activemq-website: ./ projects/artemis/download/ projects/classic/download/ projects/cms/download/ security-advisories.data/
- https://github.com/apache/activemq/commit/994d9b26
- https://github.com/apache/activemq/commit/f8b3de86d8154db5680433e46734b2bd9ced852b
- https://github.com/apache/activemq
- https://issues.apache.org/jira/browse/AMQ-5033
- https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2@%3Ccommits.activemq.apache.org%3E
- https://web.archive.org/web/20161110092459/http://secunia.com/advisories/62649
- https://web.archive.org/web/20200228044455/http://www.securityfocus.com/bid/72511
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-8110 · CVE Program
- CVE-2014-8110 · NVD
- FIRST EPSS
- GHSA-9cvr-8xq4-2m73 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences