Read the docs
TI-2014-07135 Aliases CVE-2014-8684GHSA-w9ph-q4h9-rwq6

CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it…

Priority HIGH 80CWE-310Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.

Why it matters now

EPSS 0.72161 99th percentileScored 2026-11-07
Fix Fixed codeigniter/framework (Packagist): 3.0.0kohana/core (Packagist): 3.3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—codeigniter/framework (Packagist)before 3.0.03.0.0Patch availableGHSA-w9ph-q4h9-rwq6
—kohana/core (Packagist)before 3.3.33.3.3Patch availableGHSA-w9ph-q4h9-rwq6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • codeigniter/framework (Packagist) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-w9ph-q4h9-rwq6
  • kohana/core (Packagist) Vendor— Affected before 3.3.3 Fixed in 3.3.3 Patch available GHSA-w9ph-q4h9-rwq6

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:*up to 2.2.6Vulnerablecodeigniter4
cpe:2.3:a:kohanaframework:kohana:3.2.3:*:*:*:*:*:*:*3.2.3VulnerableKohanaframework
cpe:2.3:a:kohanaframework:kohana:3.3.0:*:*:*:*:*:*:*3.3.0VulnerableKohanaframework
cpe:2.3:a:kohanaframework:kohana:3.3.1:*:*:*:*:*:*:*3.3.1VulnerableKohanaframework
  • cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* Versions up to 2.2.6 Vulnerable ·codeigniter4
  • cpe:2.3:a:kohanaframework:kohana:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·Kohanaframework
  • cpe:2.3:a:kohanaframework:kohana:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Kohanaframework
  • cpe:2.3:a:kohanaframework:kohana:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Kohanaframework

Remediation

  • Fix · GHSA-w9ph-q4h9-rwq6 codeigniter/framework (Packagist) Fixed in 3.0.0 Advisory →
  • Fix · GHSA-w9ph-q4h9-rwq6 kohana/core (Packagist) Fixed in 3.3.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-8684
  2. 2026-10-03 Alias added: GHSA-w9ph-q4h9-rwq6

References

Sources