Read the docs

codeigniter4

Records49All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical25CVSS 9.0–10.0
CVSS high10CVSS 7.0–8.9

Exploited now

codeigniter4 records in CISA KEV

No codeigniter4 vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

49 records

Priority HIGH 80

CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.72161 Published 2017-09-19 Fixed in 3.0.0, 3.3.3 CWE-310
Priority HIGH 66

CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00773 Published 2024-03-29 Fixed in 4.4.7 CWE-835
Priority MEDIUM 57

A vulnerability classified as problematic has been found in CodeIgniter Ecommerce-CodeIgniter-Bootstrap up to 1998845073cf433bc6c250b0354461fbd84d0e03.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00519 Published 2024-07-05 No fix listed CWE-79
TI-2022-19424 CVE-2022-40830 · GHSA-8vpr-6j25-gxcc

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php where_not_in() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19423 CVE-2022-40829 · GHSA-8j68-m69v-7x9f

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_like() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19422 CVE-2022-40828 · GHSA-3mpc-949c-h3m6

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where_not_in() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19421 CVE-2022-40827 · GHSA-jv9q-9872-3fqh

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php where() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01042 Published 2022-10-07 No fix listed CWE-89
TI-2022-19420 CVE-2022-40826 · GHSA-cjcg-hc25-x29f

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_having() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19418 CVE-2022-40824 · GHSA-6x3c-285p-52r4

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
Priority MEDIUM 47

SQL injection vulnerability in the offset method in the Active Record class in CodeIgniter before 2.2.4 allows remote attackers to execute arbitrary SQL commands via vectors involving the offset variable.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.02321 Published 2018-02-21 No fix listed CWE-89
TI-2022-19429 CVE-2022-40835 · GHSA-6646-39mj-h9x4

B.C.

Priority MEDIUM 44

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
Load more
Open these records in search →