Docker before 1.3.3 does not properly validate image IDs, which allows remote attackers…
Priority LOW 33CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Docker before 1.3.3 does not properly validate image IDs, which allows remote attackers to conduct path traversal attacks and spoof repositories via a crafted image in a (1) "docker load" operation or (2) "registry communications."
Why it matters now
EPSS 0.02527 84th percentileScored 2026-11-07
Fix Fixed github.com/docker/docker (Go): 1.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/docker/docker (Go) | before 1.3.2 | 1.3.2 | Patch available | GHSA-qmmc-jppf-32wv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/docker/docker (Go) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-qmmc-jppf-32wv
Remediation
- Fix · GHSA-qmmc-jppf-32wv github.com/docker/docker (Go) Fixed in 1.3.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 Extras | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-9358
- 2026-10-03 Alias added: GHSA-qmmc-jppf-32wv
References
More Docker vulnerabilities
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2019-10626 In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code… CVSS 3.1CRITICAL 9.8
- TI-2014-07591 Docker 1.3.2 allows remote attackers to execute arbitrary code with root privileges via a… CVSS 2.0HIGH 10.0
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2014-07590 Path traversal vulnerability in Docker before 1.3.3 allows remote attackers to write to… CVSS 3.1HIGH 8.6
Sources
- CVE-2014-9358 · CVE Program
- CVE-2014-9358 · NVD
- FIRST EPSS
- GHSA-qmmc-jppf-32wv · GitHub Advisory Database · CC BY 4.0
- CVE-2014-9358 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences