Out-of-bounds write in github.com/cloudflare/golz4
Priority MEDIUM 51CWE-787Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-787 and the CVSS impact.
Summary
LZ4 bindings use a deprecated C API that is vulnerable to memory corruption, which could lead to arbitrary code execution if called with untrusted user input.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01153 67th percentileScored 2026-11-07
Fix Fixed github.com/cloudflare/golz4 (github.com/cloudflare/golz4): 0.0.0-20140711154735-199f5f787806github.com/cloudflare/golz4 (Go): 0.0.0-20140711154735-199f5f787806
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| github.com/cloudflare/golz4 | github.com/cloudflare/golz4 | before 0.0.0-20140711154735-199f5f787806 | 0.0.0-20140711154735-199f5f787806 | Patch available | CNA |
| — | github.com/cloudflare/golz4 (Go) | before 0.0.0-20140711154735-199f5f787806 | 0.0.0-20140711154735-199f5f787806 | Patch available | GHSA-4wp2-8rm2-jgmh |
- github.com/cloudflare/golz4 Vendorgithub.com/cloudflare/golz4 Affected before 0.0.0-20140711154735-199f5f787806 Fixed in 0.0.0-20140711154735-199f5f787806 Patch available CNA
- github.com/cloudflare/golz4 (Go) Vendor— Affected before 0.0.0-20140711154735-199f5f787806 Fixed in 0.0.0-20140711154735-199f5f787806 Patch available GHSA-4wp2-8rm2-jgmh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudflare:golz4:*:*:*:*:*:go:*:* | before 2014-07-11 | Vulnerable | Cloudflare |
- cpe:2.3:a:cloudflare:golz4:*:*:*:*:*:go:*:* Versions before 2014-07-11 Vulnerable ·Cloudflare
Remediation
- Fix · CNA github.com/cloudflare/golz4 (github.com/cloudflare/golz4) Fixed in 0.0.0-20140711154735-199f5f787806
- Fix · GHSA-4wp2-8rm2-jgmh github.com/cloudflare/golz4 (Go) Fixed in 0.0.0-20140711154735-199f5f787806 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2014-125026
- 2026-10-03 Alias added: GHSA-4wp2-8rm2-jgmh
References
Sources
- CVE-2014-125026 · CVE Program
- CVE-2014-125026 · NVD
- FIRST EPSS
- GHSA-4wp2-8rm2-jgmh · GitHub Advisory Database · CC BY 4.0
- CVE-2014-125026 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences