Priority HIGH 68
Description: To issue and renew TLS certificates on behalf of customers, Cloudflare's Universal SSL feature automatically manages the CAA RRset for the customer's zone.
CVSS 4.0HIGH 7.6· Adjacent network · No auth · No interaction · EPSS 0.00198 · Published 2026-07-01 · No fix listed CWE-693
Priority MEDIUM 54
The Cloudflare Vite plugin enables a full-featured integration between Vite and the Workers runtime.
CVSS 4.0LOW 2.9· Network · No auth · No interaction · EPSS 0.00384 · Published 2025-09-19 · Fixed in 1.6.0 CWE-200
Priority MEDIUM 51
LZ4 bindings use a deprecated C API that is vulnerable to memory corruption, which could lead to arbitrary code execution if called with untrusted user input.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01153 · Published 2022-12-27 · Fixed in 0.0.0-20140711154735-199f5f787806 CWE-787
Priority MEDIUM 49
OctoRPKI does not escape a URI with a filename containing "..", this allows a repository to create a file, (ex.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04199 · Published 2021-11-11 · Fixed in 1.4.3, 1.4.4 CWE-20
Priority MEDIUM 48
An unchecked read in NTP server in github.com/cloudflare/cfnts prior to commit 783490b https://github.com/cloudflare/cfnts/commit/783490b913f05e508a492cd7b02e3c4ec2297b71 enabled a remote attacker to trigger a panic by s…
CVSS 3.1HIGH 8.6· Network · No auth · No interaction · EPSS 0.02237 · Published 2023-06-14 · Fixed CWE-119
Priority MEDIUM 47
An HTTP Request Smuggling vulnerability (CWE-444) has been found in Pingora's parsing of HTTP/1.0 and Transfer-Encoding requests.
CVSS 4.0CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.00793 · Published 2026-03-04 · Fixed in 0.8.0 CWE-444
Priority MEDIUM 47
An HTTP request smuggling vulnerability (CWE-444) was found in Pingora's handling of HTTP/1.1 connection upgrades.
CVSS 4.0CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.00669 · Published 2026-03-04 · Fixed in 0.8.0 CWE-444
Priority MEDIUM 44
Cloudflare quiche was discovered to be vulnerable to an infinite loop when sending packets containing RETIRE_CONNECTION_ID frames.
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.00449 · Published 2025-08-07 · Fixed in 0.24.5 CWE-835
Priority MEDIUM 42
A Server-Side Request Forgery (SSRF) vulnerability was identified in the @opennextjs/cloudflare package.
CVSS 4.0HIGH 7.8· Network · No auth · No interaction · EPSS 0.00967 · Published 2025-06-16 · Fixed in 1.3.0 CWE-918
Priority MEDIUM 42
support_uri parameter in the WARP client local settings file (mdm.xml) lacked proper validation which allowed for privilege escalation and launching an arbitrary executable on the local machine upon clicking on the "Send…
CVSS 3.1HIGH 8.9· Network · Low privileges · User interaction · EPSS 0.00714 · Published 2023-01-11 · No fix listed CWE-20
Priority MEDIUM 42
It was possible to bypass policies configured for Zero Trust Secure Web Gateway by using warp-cli 'set-custom-endpoint' subcommand.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00442 · Published 2022-10-28 · Fixed in 2022.8.857.0, 2022.8.936 +1 CWE-862
Priority MEDIUM 41
Description Cloudflare was recently notified by external researchers of vulnerabilities in this archived repository, including a remote code execution issue in `src/index.ts` reachable from certain GitHub Actions workflo…
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.0068 · Published 2026-08-12 · No fix listed CWE-1104
Priority MEDIUM 41
Impact Cloudflare quiche was discovered to be vulnerable to incorrect congestion window growth, which could cause it to send data at a rate faster than the path might actually support.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00982 · Published 2025-06-18 · Fixed in 0.24.4 CWE-770
Priority MEDIUM 41
sflow decode package does not employ sufficient packet sanitisation which can lead to a denial of service attack.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00971 · Published 2022-09-30 · Fixed in 3.4.4 CWE-20
Priority MEDIUM 40
Summary Before version 0.9.0, the HTTP/1 upstream path in pingora-proxy passed the downstream request through upstream_request_filter and wrote it to the upstream without removing the client's Connection header, other ho…
CVSS 3.1HIGH 8.7· Network · No auth · No interaction · EPSS 0.00425 · Published 2026-10-20 · Fixed in 0.9.0 CWE-444
Priority MEDIUM 40
Summary Cloudflare quiche's HTTP/3 layer was discovered to be vulnerable to resource exhaustion (i.e., memory) by means of specially crafted HTTP/3 frames.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00532 · Published 2026-07-14 · Fixed in 0.29.3 CWE-400
Priority MEDIUM 40
lol-html can cause panics on certain HTML inputs.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00687 · Published 2023-08-16 · Fixed in 1.1.1 CWE-20
Priority LOW 39
Summary Before version 0.8.1, Pingora's HTTP/2 server used the h2 crate's default limits unless the application set its own 16 MiB decoded header-list size and no limit on concurrent streams.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00429 · Published 2026-10-20 · Fixed in 0.8.1 CWE-770
Priority LOW 39
Summary Cloudflare quiche was discovered to be vulnerable to memory resource exhaustion due to unbounded queuing of post-handshake client migration events.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00441 · Published 2026-07-14 · Fixed in 0.29.3 CWE-770
Priority LOW 39
SummaryA command injection vulnerability (CWE-78) has been found to exist in the `wrangler pages deploy` command.
CVSS 4.0HIGH 7.7· Network · Low privileges · No interaction · EPSS 0.01514 · Published 2026-01-20 · Fixed in 3.114.17, 4.59.1 CWE-20
Priority LOW 39
The Cloudflare Wordpress plugin was found to be vulnerable to improper authentication.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.00801 · Published 2024-01-29 · No fix listed CWE-284
Priority LOW 39
Cloudflare WARP client for Windows (up to v2023.3.381.0) allowed a malicious actor to remotely access the warp-svc.exe binary due to an insufficient access control policy on an IPC Named Pipe.
CVSS 3.1HIGH 7.3· Network · No auth · No interaction · EPSS 0.00754 · Published 2023-06-20 · Fixed in 2023.3.381.0 CWE-284
Priority LOW 38
The V8 inspector intentionally allows arbitrary code execution within the Workers sandbox for debugging.
CVSS 3.1HIGH 8.5· Adjacent network · No auth · User interaction · EPSS 0.0063 · Published 2023-12-29 · Fixed in 3.19.0, 2.20.2 CWE-269
Priority LOW 38
Sending specially crafted HTTP requests to Miniflare's server could result in arbitrary HTTP and WebSocket requests being sent from the server.
CVSS 3.1HIGH 8.1· Adjacent network · No auth · No interaction · EPSS 0.00552 · Published 2023-12-29 · Fixed in 3.20231030.2 CWE-918
Priority LOW 38
Using warp-cli command "add-trusted-ssid", a user was able to disconnect WARP client and bypass the "Lock WARP switch" feature resulting in Zero Trust policies not being enforced on an affected endpoint.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0046 · Published 2022-10-28 · Fixed in 2022.8.857, 2022.8.936 +1 CWE-862
Load more