VaultPress Plugin MailPoet Plugin class.vaultpress-hotfixes.php protect_aioseo_ajax unrestricted upload
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
A vulnerability was found in VaultPress Plugin up to 1.6.0 on WordPress. It has been declared as critical. Affected by this vulnerability is the function protect_aioseo_ajax of the file class.vaultpress-hotfixes.php of the component MailPoet Plugin. The manipulation leads to unrestricted upload. The attack can be launched remotely. Upgrading to version 1.6.1 is able to address this issue. The patch is named e3b92b14edca6291c5f998d54c90cbe98a1fb0e3. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230263.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | VaultPress Plugin | 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6 | — | No fix listed | CNA |
- VaultPress Plugin Vendor— Affected 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automattic:vaultpress:*:*:*:*:*:wordpress:*:* | before 1.6.1 | Vulnerable | Automattic |
- cpe:2.3:a:automattic:vaultpress:*:*:*:*:*:wordpress:*:* Versions before 1.6.1 Vulnerable ·Automattic
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2014-125104
- 2026-10-03 Alias added: GHSA-rf67-fgh6-8jjv
References
More Automattic Vaultpress vulnerabilities
- TI-2017-14152 VaultPress Plugin code injection CVSS 3.1HIGH 7.5
Sources
- CVE-2014-125104 · CVE Program
- CVE-2014-125104 · NVD
- FIRST EPSS
- GHSA-rf67-fgh6-8jjv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences