Read the docs

Broken Link Checker Plugin Settings Page core.php options_page cross site scripting

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

A vulnerability was found in Broken Link Checker Plugin up to 1.10.1 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function options_page of the file core/core.php of the component Settings Page. The manipulation of the argument exclusion_list/blc_custom_fields leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.10.2 is able to address this issue. The patch is named 90615fe9b0b6f9e6fb254d503c302e53a202e561. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230659.

Why it matters now

EPSS 0.00545 45th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Broken Link Checker Plugin1.10.0; 1.10.1—No fix listedCNA
  • Broken Link Checker Plugin Vendor— Affected 1.10.0; 1.10.1 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:managewp:broken_link_checker:*:*:*:*:*:wordpress:*:*up to 1.10.1VulnerableManageWP
  • cpe:2.3:a:managewp:broken_link_checker:*:*:*:*:*:wordpress:*:* Versions up to 1.10.1 Vulnerable ·ManageWP

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-125105
  2. 2026-10-03 Alias added: GHSA-5crm-f6x3-hr2w

References

  • TI-2024-10107 Broken Link Checker < 2.4.2 - Admin+ SSRF CVSS 3.1MEDIUM 4.7
  • TI-2022-03597 Broken Link Checker < 1.11.20 - Admin+ Cross-Site Scripting CVSS 3.1MEDIUM 4.8
  • TI-2023-09550 WordPress MainWP Broken Links Checker Extension Plugin <= 4.0 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2022-02252 Broken Link Checker <= 1.11.16 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
  • TI-2019-12386 The broken-link-checker plugin through 1.11.8 for WordPress (aka Broken Link Checker) is… CVSS 3.1MEDIUM 6.1
  • TI-2019-12827 A reflected XSS vulnerability was found in includes/admin/table-printer.php in the… CVSS 3.1MEDIUM 5.4

Sources