Broken Link Checker < 1.11.20 - Admin+ Cross-Site Scripting
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Broken Link Checker WordPress plugin before 1.11.20 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00531 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Broken Link Checker (Unknown): 1.11.20
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Broken Link Checker | before 1.11.20 | 1.11.20 | Patch available | CNA |
- Broken Link Checker VendorUnknown Affected before 1.11.20 Fixed in 1.11.20 Patch available CNA
Remediation
- Fix · CNA Broken Link Checker (Unknown) Fixed in 1.11.20
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3922
- 2026-10-03 Alias added: GHSA-r8w3-884p-p4g2
References
More ManageWP Broken Link Checker vulnerabilities
- TI-2024-10107 Broken Link Checker < 2.4.2 - Admin+ SSRF CVSS 3.1MEDIUM 4.7
- TI-2023-09550 WordPress MainWP Broken Links Checker Extension Plugin <= 4.0 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2022-02252 Broken Link Checker <= 1.11.16 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
- TI-2019-12386 The broken-link-checker plugin through 1.11.8 for WordPress (aka Broken Link Checker) is… CVSS 3.1MEDIUM 6.1
- TI-2019-12827 A reflected XSS vulnerability was found in includes/admin/table-printer.php in the… CVSS 3.1MEDIUM 5.4
- TI-2014-08405 Broken Link Checker Plugin Settings Page core.php options_page cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-3922 · CVE Program
- CVE-2022-3922 · NVD
- FIRST EPSS
- GHSA-r8w3-884p-p4g2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences