Out-of-bounds write in PostgreSQL
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PostgreSQL | PostgreSQL | before 9.0.19; 9.1 to before 9.1.15; 9.2 to before 9.2.10; 9.3 to before 9.3.6; 9.4 to before 9.4.1 | 9.0.19, 9.1.15, 9.2.10, 9.3.6, 9.4.1 | Patch available | CNA |
- PostgreSQL VendorPostgreSQL Affected before 9.0.19; 9.1 to before 9.1.15; 9.2 to before 9.2.10; 9.3 to before 9.3.6; 9.4 to before 9.4.1 Fixed in 9.0.19, 9.1.15, 9.2.10, 9.3.6, 9.4.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* | before 9.0.19; 9.1.0 to before 9.1.15; 9.2.0 to before 9.2.10; 9.3.0 to before 9.3.6; 9.4.0 to before 9.4.1 | Vulnerable | PostgreSQL |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* Versions before 9.0.19; 9.1.0 to before 9.1.15; 9.2.0 to before 9.2.10; 9.3.0 to before 9.3.6; 9.4.0 to before 9.4.1 Vulnerable ·PostgreSQL
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · CNA PostgreSQL (PostgreSQL Global Development Group) Fixed in 9.0.19, 9.1.15, 9.2.10, 9.3.6, 9.4.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 6 products
- CloudForms Management Engine 5
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Satellite 5
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0242
- 2026-10-03 Alias added: GHSA-484w-vg65-78pg
References
Advisory 7
- http://www.postgresql.org/docs/9.4/static/release-9-4-1.html
- http://www.postgresql.org/docs/current/static/release-9-0-19.html
- http://www.postgresql.org/docs/current/static/release-9-1-15.html
- http://www.postgresql.org/docs/current/static/release-9-2-10.html
- http://www.postgresql.org/docs/current/static/release-9-3-6.html
- http://www.postgresql.org/about/news/1569/
- http://www.debian.org/security/2015/dsa-3155
More Postgresql vulnerabilities
- TI-2019-06651 In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and… CVSS 3.0HIGH 7.2
- TI-2017-05187 Improper authentication in postgresql CVSS 3.0CRITICAL 9.8
- TI-2020-15711 SQL injection in postgresql CVSS 3.1HIGH 8.8
- TI-2013-01675 Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9… CVSS 2.0MEDIUM 6.5
- TI-2007-03176 The Database Link library (dblink) in PostgreSQL 8.1 implements functions via CREATE… CVSS 2.0HIGH 9.0
- TI-2022-01423 SQL injection in postgresql CVSS 3.1HIGH 8.8
Sources
- CVE-2015-0242 · CVE Program
- CVE-2015-0242 · NVD
- FIRST EPSS
- GHSA-484w-vg65-78pg · GitHub Advisory Database · CC BY 4.0
- CVE-2015-0242 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences