Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 7.4.0 allows remote…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 7.4.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.01762 78th percentileScored 2026-11-07
Fix Fixed DotNetNuke.Core (NuGet): 7.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | DotNetNuke.Core (NuGet) | before 7.4.0 | 7.4.0 | Patch available | GHSA-v76m-f5cx-8rg4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- DotNetNuke.Core (NuGet) Vendor— Affected before 7.4.0 Fixed in 7.4.0 Patch available GHSA-v76m-f5cx-8rg4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* | up to 07.03.04 | Vulnerable | DotNetNuke (DNN) |
- cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* Versions up to 07.03.04 Vulnerable ·DotNetNuke (DNN)
Remediation
- Fix · GHSA-v76m-f5cx-8rg4 DotNetNuke.Core (NuGet) Fixed in 7.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1566
- 2026-10-03 Alias added: GHSA-v76m-f5cx-8rg4
References
More DotNetNuke (DNN) Dotnetnuke vulnerabilities
- TI-2017-07201 Code injection in DotNetNuke CMS Fixed in 9.1.1 KEVCVSS 3.1HIGH 8.8
- TI-2018-12944 DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input… KEVCVSS 3.1HIGH 7.5
- TI-2018-11271 DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters. KEVCVSS 3.1HIGH 7.5
- TI-2015-02468 The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2025-39546 DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite CVSS 3.1CRITICAL 10.0
- TI-2018-12945 DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values… CVSS 3.1HIGH 7.5
Sources
- CVE-2015-1566 · CVE Program
- CVE-2015-1566 · NVD
- FIRST EPSS
- GHSA-v76m-f5cx-8rg4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences