Improper input validation in Ruby
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 7 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers to spoof servers via vectors related to (1) multiple wildcards, (1) wildcards in IDNA names, (3) case sensitivity, and (4) non-ASCII characters.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ruby | Ruby | before 2.0.0 patchlevel 645; 2.1 to before 2.1.6; and 2.2.x before 2.2.2 | 2.1.6 | Patch available | CNA |
- Ruby Vendorruby Affected before 2.0.0 patchlevel 645; 2.1 to before 2.1.6; and 2.2.x before 2.2.2 Fixed in 2.1.6 Patch available CNA
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* | 2.1.0 to before 2.1.6; 2.2.0 to before 2.2.2 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:-:*:*:*:*:*:* | 2.0.0 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p0:*:*:*:*:*:* | 2.0.0 p0 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p195:*:*:*:*:*:* | 2.0.0 p195 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p247:*:*:*:*:*:* | 2.0.0 p247 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p353:*:*:*:*:*:* | 2.0.0 p353 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p451:*:*:*:*:*:* | 2.0.0 p451 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p481:*:*:*:*:*:* | 2.0.0 p481 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p576:*:*:*:*:*:* | 2.0.0 p576 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p594:*:*:*:*:*:* | 2.0.0 p594 | Vulnerable | ruby |
- cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:* Versions 2.1.0 to before 2.1.6; 2.2.0 to before 2.2.2 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:-:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p0:*:*:*:*:*:* Versions 2.0.0 p0 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p195:*:*:*:*:*:* Versions 2.0.0 p195 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p247:*:*:*:*:*:* Versions 2.0.0 p247 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p353:*:*:*:*:*:* Versions 2.0.0 p353 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p451:*:*:*:*:*:* Versions 2.0.0 p451 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p481:*:*:*:*:*:* Versions 2.0.0 p481 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p576:*:*:*:*:*:* Versions 2.0.0 p576 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p594:*:*:*:*:*:* Versions 2.0.0 p594 Vulnerable ·ruby
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p598:*:*:*:*:*:* | 2.0.0 p598 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:ruby:2.0.0:p643:*:*:*:*:*:* | 2.0.0 p643 | Vulnerable | ruby |
| cpe:2.3:a:ruby-lang:trunk:*:*:*:*:*:*:*:* | before 50292 | Vulnerable | ruby |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:a:puppet:puppet_agent:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* | 3.0.0 to before 3.8.0 | Vulnerable | Puppet |
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p598:*:*:*:*:*:* Versions 2.0.0 p598 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:ruby:2.0.0:p643:*:*:*:*:*:* Versions 2.0.0 p643 Vulnerable ·ruby
- cpe:2.3:a:ruby-lang:trunk:*:*:*:*:*:*:*:* Versions before 50292 Vulnerable ·ruby
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:a:puppet:puppet_agent:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.8.0 Vulnerable ·Puppet
Remediation
- Fix · CNA Ruby (Ruby) Fixed in 2.1.6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix yet |
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix yet |
Not affected: 1 product
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1855
- 2026-10-03 Alias added: GHSA-4x8v-74xf-h4g3
References
Advisory 6
- http://www.debian.org/security/2015/dsa-3247
- http://www.debian.org/security/2015/dsa-3245
- http://www.debian.org/security/2015/dsa-3246
- https://www.ruby-lang.org/en/news/2015/04/13/ruby-openssl-hostname-matching-vulnerability/
- https://puppetlabs.com/security/cve/cve-2015-1855
- https://bugs.ruby-lang.org/issues/9644
More Ruby vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2017-12709 Ruby before 2.4.3 allows Net::FTP command injection. CVSS 3.0HIGH 8.8
- TI-2008-03501 Algorithmic complexity vulnerability in the WEBrick::HTTPUtils.split_header_value… CVSS 2.0HIGH 7.8
- TI-2021-09891 In Ruby through 3.0 on Windows, a remote attacker can submit a crafted path when a Web… CVSS 3.1HIGH 7.5
- TI-2013-03637 Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1… CVSS 2.0MEDIUM 6.8
- TI-2018-11751 An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2015-1855 · CVE Program
- CVE-2015-1855 · NVD
- FIRST EPSS
- GHSA-4x8v-74xf-h4g3 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-1855 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences