Apache Struts before 2.3.20 has a cross-site scripting (XSS) vulnerability.
Priority LOW 36CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Apache Struts before 2.3.20 has a cross-site scripting (XSS) vulnerability.
Why it matters now
EPSS 0.05757 93rd percentileScored 2026-11-07
Fix Partial Apache Struts (Apache Software Foundation): 2.3.20org.apache.struts:struts2-core (Maven): 2.3.20Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Struts | before 2.3.20 | 2.3.20 | Patch available | CNA |
| — | org.apache.struts:struts2-core (Maven) | before 2.3.20 | 2.3.20 | Patch available | GHSA-265r-pp83-gww7 |
- Apache Struts VendorApache Affected before 2.3.20 Fixed in 2.3.20 Patch available CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected before 2.3.20 Fixed in 2.3.20 Patch available GHSA-265r-pp83-gww7
Remediation
- Fix · CNA Apache Struts (Apache Software Foundation) Fixed in 2.3.20
- Fix · GHSA-265r-pp83-gww7 org.apache.struts:struts2-core (Maven) Fixed in 2.3.20 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 5 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-2992
- 2026-10-03 Alias added: GHSA-265r-pp83-gww7
References
Advisory 4
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2015-2992 · CVE Program
- CVE-2015-2992 · NVD
- FIRST EPSS
- GHSA-265r-pp83-gww7 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-2992 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences