The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial…
Priority LOW 39CWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-119 and the CVSS impact.
Summary
The tlslite library before 0.4.9 for Python allows remote attackers to trigger a denial of service (runtime exception and process crash).
Why it matters now
EPSS 0.03293 88th percentileScored 2026-11-07
Fix Fixed tlslite (PyPI): 0.4.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | tlslite (PyPI) | before 0.4.9 | 0.4.9 | Patch available | GHSA-4749-p7rx-8jjj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- tlslite (PyPI) Vendor— Affected before 0.4.9 Fixed in 0.4.9 Patch available GHSA-4749-p7rx-8jjj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tlslite_project:tlslite:*:*:*:*:*:python:*:* | up to 0.4.9 | Vulnerable | Tlslite Project |
- cpe:2.3:a:tlslite_project:tlslite:*:*:*:*:*:python:*:* Versions up to 0.4.9 Vulnerable ·Tlslite Project
Remediation
- Fix · GHSA-4749-p7rx-8jjj tlslite (PyPI) Fixed in 0.4.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3220
- 2026-10-03 Alias added: GHSA-4749-p7rx-8jjj
References
Advisory 2
Sources
- CVE-2015-3220 · CVE Program
- CVE-2015-3220 · NVD
- FIRST EPSS
- GHSA-4749-p7rx-8jjj · GitHub Advisory Database · CC BY 4.0
- CVE-2015-3220 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences