lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails…
Priority LOW 34CWE-19Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Partial Red Hat: 6 fixed, 6 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.
Why it matters now
EPSS 0.07935 94th percentileScored 2026-11-07
Fix Partial rack (RubyGems): 1.5.4, 1.6.2, 1.4.6Red Hat: 1 advisoryRed Hat: 6 fixed, 6 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rack (RubyGems) | 1.5.0 to before 1.5.4 | 1.5.4 | Patch available | GHSA-rgr4-9jh5-j4j6 |
| — | rack (RubyGems) | 1.6.0 to before 1.6.2 | 1.6.2 | Patch available | GHSA-rgr4-9jh5-j4j6 |
| — | rack (RubyGems) | 1.4.0 to before 1.4.6 | 1.4.6 | Patch available | GHSA-rgr4-9jh5-j4j6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rack (RubyGems) Vendor— Affected 1.5.0 to before 1.5.4 Fixed in 1.5.4 Patch available GHSA-rgr4-9jh5-j4j6
- rack (RubyGems) Vendor— Affected 1.6.0 to before 1.6.2 Fixed in 1.6.2 Patch available GHSA-rgr4-9jh5-j4j6
- rack (RubyGems) Vendor— Affected 1.4.0 to before 1.4.6 Fixed in 1.4.6 Patch available GHSA-rgr4-9jh5-j4j6
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rack_project:rack:*:*:*:*:*:*:*:* | up to 1.5.3 | Vulnerable | Rack Project |
| cpe:2.3:a:rack_project:rack:1.6.0:*:*:*:*:*:*:* | 1.6.0 | Vulnerable | Rack Project |
| cpe:2.3:a:rack_project:rack:1.6.1:*:*:*:*:*:*:* | 1.6.1 | Vulnerable | Rack Project |
| cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* | 13.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* | 13.2 | Vulnerable | openSUSE |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:rack_project:rack:*:*:*:*:*:*:*:* Versions up to 1.5.3 Vulnerable ·Rack Project
- cpe:2.3:a:rack_project:rack:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·Rack Project
- cpe:2.3:a:rack_project:rack:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·Rack Project
- cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-rgr4-9jh5-j4j6 rack (RubyGems) Fixed in 1.5.4 Advisory →
- Fix · GHSA-rgr4-9jh5-j4j6 rack (RubyGems) Fixed in 1.6.2 Advisory →
- Fix · GHSA-rgr4-9jh5-j4j6 rack (RubyGems) Fixed in 1.4.6 Advisory →
Red Hat 1 advisory
- RHSA-2015:2290 Released 2015-11-19 · Red Hat rating Moderatepcs security, bug fix, and enhancement update
- Red Hat Enterprise Linux Server High Availability (v. 7) pcs-0.9.143-15.el7
- Red Hat Enterprise Linux Server Resilient Storage (v. 7) pcs-0.9.143-15.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| OpenStack Foreman | Affected | No fix planned: Will not fix |
| Red Hat Enterprise MRG 2 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Server High Availability (v. 7) | Fixed | RHSA-2015:2290 |
| Red Hat Enterprise Linux Server Resilient Storage (v. 7) | Fixed | RHSA-2015:2290 |
| Red Hat Satellite 6.3 | Fixed | — |
| Red Hat Satellite 6.3 - Puppet 4 | Fixed | — |
| Red Hat Satellite Capsule 6.3 | Fixed | — |
| Red Hat Satellite Capsule 6.3 - Puppet 4 | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3225
- 2026-10-03 Alias added: GHSA-rgr4-9jh5-j4j6
References
Advisory 10
- openSUSE-SU-2015:1262
- openSUSE-SU-2015:1263
- RHSA-2015:2290
- FEDORA-2015-12979
- [rubyonrails-security] 20150616 [CVE-2015-3225] Potential Denial of Service Vulnerability in Rack
- DSA-3322
- openSUSE-SU-2015:1259
- FEDORA-2015-12978
- [oss-security] 20150616 [CVE-2015-3225] Potential Denial of Service Vulnerability in Rack
- https://nvd.nist.gov/vuln/detail/CVE-2015-3225
Sources
- CVE-2015-3225 · CVE Program
- CVE-2015-3225 · NVD
- FIRST EPSS
- GHSA-rgr4-9jh5-j4j6 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-3225 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences