Read the docs

Rack Project

Records13All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high4CVSS 7.0–8.9

Exploited now

Rack Project records in CISA KEV

No Rack Project vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

13 records

Priority MEDIUM 43

A possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.02231 Published 2022-12-05 Partial fix · 2.0.9.1, 2.1.4.1 +1 CWE-400
Priority MEDIUM 43

A directory traversal vulnerability exists in rack < 2.2.0 that allows an attacker perform directory traversal vulnerability in the Rack::Directory app that is bundled with Rack which could result in information disclosu…

CVSS 3.1HIGH 8.6 Network No auth No interaction EPSS 0.03359 Published 2020-07-02 Partial fix · 2.1.3 CWE-548
Priority LOW 38

A reliance on cookies without validation/integrity check security vulnerability exists in rack < 2.2.3, rack < 2.1.4 that makes it is possible for an attacker to forge a secure or host-only cookie prefix.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.03011 Published 2020-06-19 Partial fix · 2.1.4, 2.2.3 CWE-784
TI-2018-11812 CVE-2018-16470 · GHSA-hg78-4f6x-99wq

Uncontrolled resource consumption in Rack

Priority LOW 37

There is a possible DoS vulnerability in the multipart parser in Rack before 2.0.6.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.02033 Published 2018-11-13 Partial fix · 2.0.6 CWE-400
Priority LOW 34

lib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.07935 Published 2015-07-26 Partial fix · 1.5.4, 1.6.2 +1 CWE-19
Priority LOW 32

Rack::Session::Cookie in Rack 1.5.x before 1.5.2, 1.4.x before 1.4.5, 1.3.x before 1.3.10, 1.2.x before 1.2.8, and 1.1.x before 1.1.6 allows remote attackers to guess the session cookie, gain privileges, and execute arbi…

CVSS 2.0MEDIUM 5.1 Network No auth Interaction — EPSS 0.05383 Published 2013-02-08 Partial fix · 1.5.2, 1.4.5 +3
TI-2018-11813 CVE-2018-16471 · GHSA-5r2p-j47h-mhpg

Cross-site scripting in Rack

Priority LOW 31

There is a possible XSS vulnerability in Rack before 2.0.6 and 1.6.11.

CVSS 3.0MEDIUM 6.1 Network No auth User interaction EPSS 0.0189 Published 2018-11-13 Partial fix · 2.0.6, 1.6.11 CWE-79
Priority LOW 29

multipart/parser.rb in Rack 1.3.x before 1.3.8 and 1.4.x before 1.4.3 allows remote attackers to cause a denial of service (memory consumption and out-of-memory error) via a long string in a Multipart HTTP packet.

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.03778 Published 2013-03-01 Partial fix · 1.3.8, 1.4.3 CWE-119
Priority LOW 29

Rack before 1.1.3, 1.2.x before 1.2.5, and 1.3.x before 1.3.6 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a deni…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.03871 Published 2011-12-30 Partial fix · 1.1.3, 1.2.5 +2 CWE-310
Priority LOW 25

rack/file.rb (Rack::File) in Rack 1.5.x before 1.5.2 and 1.4.x before 1.4.5 allows attackers to access arbitrary files outside the intended root directory via a crafted PATH_INFO environment variable, probably a director…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.02941 Published 2013-02-08 Fixed in 1.5.2, 1.4.5 CWE-22
Priority LOW 25

Unspecified vulnerability in Rack::Auth::AbstractRequest in Rack 1.1.x before 1.1.5, 1.2.x before 1.2.7, 1.3.x before 1.3.9, and 1.4.x before 1.4.4 allows remote attackers to cause a denial of service via unknown vectors…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.02418 Published 2013-03-01 Partial fix · 1.1.5, 1.2.7 +2
Priority LOW 25

lib/rack/multipart.rb in Rack before 1.1.4, 1.2.x before 1.2.6, 1.3.x before 1.3.7, and 1.4.x before 1.4.2 uses an incorrect regular expression, which allows remote attackers to cause a denial of service (infinite loop)…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.02717 Published 2013-03-01 Partial fix · 1.1.4, 1.2.6 +2 CWE-835
Open these records in search →