Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) javascript: or (2) data: URLs.
Why it matters now
EPSS 0.01265 69th percentileScored 2026-11-07
Fix Fixed nodebb (npm): 0.70nodebb-plugin-markdown (npm): 5.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | nodebb (npm) | before 0.70 | 0.70 | Patch available | GHSA-9g4f-5rpg-4948 |
| — | nodebb-plugin-markdown (npm) | before 5.1.1 | 5.1.1 | Patch available | GHSA-9g4f-5rpg-4948 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- nodebb (npm) Vendor— Affected before 0.70 Fixed in 0.70 Patch available GHSA-9g4f-5rpg-4948
- nodebb-plugin-markdown (npm) Vendor— Affected before 5.1.1 Fixed in 5.1.1 Patch available GHSA-9g4f-5rpg-4948
Remediation
- Fix · GHSA-9g4f-5rpg-4948 nodebb (npm) Fixed in 0.70 Advisory →
- Fix · GHSA-9g4f-5rpg-4948 nodebb-plugin-markdown (npm) Fixed in 5.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3296
- 2026-10-03 Alias added: GHSA-9g4f-5rpg-4948
References
Patch 2
Other 4
- https://github.com/NodeBB/NodeBB/issues/2273
- https://github.com/NodeBB/nodebb-plugin-markdown/commit/ab7f2684750882f7baefbfa31db8d5aac71e6ec3
- https://github.com/markdown-it/markdown-it/commit/f76d3beb46abd121892a2e2e5c78376354c214e3
- https://web.archive.org/web/20200228230630/http://www.securityfocus.com/bid/71824
More Nodebb vulnerabilities
- TI-2023-23124 A remote code execution (RCE) vulnerability in the xmlrpc.php endpoint of NodeBB Inc… CVSS 3.1CRITICAL 9.8
- TI-2022-22808 Account takeover via prototype vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-42173 NodeBB - ActivityPub Author Spoofing via Unvalidated attributedTo Mapped to Local User CVSS 4.0HIGH 8.7
- TI-2025-32286 NodeBB v4.3.0 is vulnerable to SQL injection in its search-categories API endpoint… CVSS 3.1HIGH 8.6
- TI-2023-14416 NodeBB Pre-Authentication Denial-of-Service CVSS 3.1HIGH 7.5
- TI-2022-16499 Account takeover via SSO plugins in NodeBB CVSS 3.1HIGH 8.8
Sources
- CVE-2015-3296 · CVE Program
- CVE-2015-3296 · NVD
- FIRST EPSS
- GHSA-9g4f-5rpg-4948 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences